uClibc: use position independent code for crt1, slightly reduces size of all executables

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 37096
This commit is contained in:
Felix Fietkau 2013-06-30 07:54:51 +00:00
parent 98df29f9d7
commit 02a6750af8

View File

@ -0,0 +1,11 @@
--- a/libc/sysdeps/linux/mips/Makefile.arch
+++ b/libc/sysdeps/linux/mips/Makefile.arch
@@ -20,6 +20,8 @@ ifneq ($(UCLIBC_HAS_THREADS_NATIVE),y)
SSRC += vfork.S clone.S
endif
+CFLAGS-crt1.S += $(PICFLAG)
+
ASFLAGS-syscall_error.S += -D_LIBC_REENTRANT
ARCH_HEADERS := sgidefs.h