tools/libressl: Update to 3.0.2

Update libressl to 3.0.2 and remove 010-avoid-glibc.patch as fix is added by upstream

Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
This commit is contained in:
Daniel Engberg 2020-02-03 15:47:47 +00:00 committed by Hans Dedecker
parent 18c95c9d6e
commit 0ffb7b02ba
2 changed files with 2 additions and 25 deletions

View File

@ -8,8 +8,8 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libressl
PKG_VERSION:=2.9.2
PKG_HASH:=c4c78167fae325b47aebd8beb54b6041d6f6a56b3743f4bd5d79b15642f9d5d4
PKG_VERSION:=3.0.2
PKG_HASH:=df7b172bf79b957dd27ef36dcaa1fb162562c0e8999e194aa8c1a3df2f15398e
PKG_RELEASE:=1
PKG_CPE_ID:=cpe:/a:openbsd:libressl

View File

@ -1,23 +0,0 @@
From a747aacc23607c993cc481378782b2c7dd5bc53b Mon Sep 17 00:00:00 2001
From: Ishimoto Shinobu <47295761+protonesso@users.noreply.github.com>
Date: Tue, 21 May 2019 22:41:05 +0900
Subject: [PATCH] avoid glibc
cause problems on musl systems
---
crypto/compat/getprogname_linux.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
--- a/crypto/compat/getprogname_linux.c
+++ b/crypto/compat/getprogname_linux.c
@@ -26,9 +26,7 @@ getprogname(void)
#if defined(__ANDROID_API__) && __ANDROID_API__ < 21
extern const char *__progname;
return __progname;
-#elif defined(__GLIBC__)
- return program_invocation_short_name;
#else
-#error "Cannot emulate getprogname"
+ return program_invocation_short_name;
#endif
}