uml: refresh patches

SVN-Revision: 17684
This commit is contained in:
Gabor Juhos 2009-09-23 12:05:44 +00:00
parent 60132f56f7
commit 1eeff91ada
3 changed files with 6 additions and 19 deletions

View File

@ -1,6 +1,6 @@
--- a/arch/um/os-Linux/user_syms.c 2009-08-16 23:19:38.000000000 +0200
+++ b/arch/um/os-Linux/user_syms.c 2009-09-01 17:05:40.000000000 +0200
@@ -23,10 +23,8 @@
--- a/arch/um/os-Linux/user_syms.c
+++ b/arch/um/os-Linux/user_syms.c
@@ -23,10 +23,8 @@ extern int printf(const char *, ...);
EXPORT_SYMBOL(strstr);
#endif
@ -11,8 +11,8 @@
EXPORT_SYMBOL(memmove);
EXPORT_SYMBOL(memset);
--- a/arch/um/sys-x86_64/ksyms.c 2009-08-16 23:19:38.000000000 +0200
+++ b/arch/um/sys-x86_64/ksyms.c 2009-09-01 17:13:47.000000000 +0200
--- a/arch/um/sys-x86_64/ksyms.c
+++ b/arch/um/sys-x86_64/ksyms.c
@@ -2,10 +2,5 @@
#include <asm/string.h>
#include <asm/checksum.h>

View File

@ -14,8 +14,6 @@ Cc: Jeff Dike <jdike@addtoit.com>
Cc: Sam Ravnborg <sam@ravnborg.org>
---
diff --git a/arch/um/sys-x86_64/stub.S b/arch/um/sys-x86_64/stub.S
index 6d9edf9..20e4a96 100644
--- a/arch/um/sys-x86_64/stub.S
+++ b/arch/um/sys-x86_64/stub.S
@@ -1,7 +1,7 @@
@ -27,8 +25,6 @@ index 6d9edf9..20e4a96 100644
syscall_stub:
syscall
/* We don't have 64-bit constants, so this constructs the address
diff --git a/arch/um/sys-i386/stub.S b/arch/um/sys-i386/stub.S
index c41b04b..54a36ec 100644
--- a/arch/um/sys-i386/stub.S
+++ b/arch/um/sys-i386/stub.S
@@ -1,7 +1,7 @@
@ -40,8 +36,3 @@ index c41b04b..54a36ec 100644
.globl batch_syscall_stub
batch_syscall_stub:
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

View File

@ -11,11 +11,9 @@ Date: Sun Sep 6 14:36:01 2009 +0200
Signed-off-by: Paul Bolle <pebolle@tiscali.nl>
diff --git a/arch/um/Makefile b/arch/um/Makefile
index 0728def..dc1ea7d 100644
--- a/arch/um/Makefile
+++ b/arch/um/Makefile
@@ -99,9 +99,6 @@ CFLAGS_NO_HARDENING := $(call cc-option, -fno-PIC,) $(call cc-option, -fno-pic,)
@@ -99,9 +99,6 @@ CFLAGS_NO_HARDENING := $(call cc-option,
CONFIG_KERNEL_STACK_ORDER ?= 2
STACK_SIZE := $(shell echo $$[ 4096 * (1 << $(CONFIG_KERNEL_STACK_ORDER)) ] )
@ -32,8 +30,6 @@ index 0728def..dc1ea7d 100644
-export SUBARCH USER_CFLAGS CFLAGS_NO_HARDENING OS HEADER_ARCH DEV_NULL_PATH
+export SUBARCH USER_CFLAGS CFLAGS_NO_HARDENING OS HEADER_ARCH DEV_NULL_PATH \
+ ELF_ARCH ELF_FORMAT STACK_SIZE START
diff --git a/arch/um/kernel/Makefile b/arch/um/kernel/Makefile
index 388ec0a..2907436 100644
--- a/arch/um/kernel/Makefile
+++ b/arch/um/kernel/Makefile
@@ -3,6 +3,10 @@