brcm47xx: new patch adding arch workarounds.c

It was recently sent to linux-mips for comments. It adds workaround for
WNR3500L to enable USB port.

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>

SVN-Revision: 39469
This commit is contained in:
Hauke Mehrtens 2014-02-04 23:32:01 +00:00
parent 14113eb88f
commit 2ad7e55a89
4 changed files with 77 additions and 5 deletions

View File

@ -0,0 +1,72 @@
From 1f3e1c682a0b5273e3ee8799b54319971f426e6a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
Date: Wed, 29 Jan 2014 18:06:52 +0100
Subject: [RFC V2][PATCH] MIPS: BCM47XX: Add new file for device specific workarounds
---
V2: Drop pr_debug for devices we don't need workarounds for. It was too
load and not useful at all.
---
arch/mips/bcm47xx/Makefile | 2 +-
arch/mips/bcm47xx/bcm47xx_private.h | 3 +++
arch/mips/bcm47xx/setup.c | 1 +
arch/mips/bcm47xx/workarounds.c | 25 +++++++++++++++++++++++++
4 files changed, 30 insertions(+), 1 deletion(-)
create mode 100644 arch/mips/bcm47xx/workarounds.c
--- a/arch/mips/bcm47xx/Makefile
+++ b/arch/mips/bcm47xx/Makefile
@@ -4,4 +4,4 @@
#
obj-y += irq.o nvram.o prom.o serial.o setup.o time.o sprom.o
-obj-y += board.o buttons.o leds.o
+obj-y += board.o buttons.o leds.o workarounds.o
--- a/arch/mips/bcm47xx/bcm47xx_private.h
+++ b/arch/mips/bcm47xx/bcm47xx_private.h
@@ -9,4 +9,7 @@ int __init bcm47xx_buttons_register(void
/* leds.c */
void __init bcm47xx_leds_register(void);
+/* workarounds.c */
+void __init bcm47xx_workarounds(void);
+
#endif
--- a/arch/mips/bcm47xx/setup.c
+++ b/arch/mips/bcm47xx/setup.c
@@ -248,6 +248,7 @@ static int __init bcm47xx_register_bus_c
bcm47xx_buttons_register();
bcm47xx_leds_register();
+ bcm47xx_workarounds();
return 0;
}
--- /dev/null
+++ b/arch/mips/bcm47xx/workarounds.c
@@ -0,0 +1,25 @@
+#include "bcm47xx_private.h"
+
+#include <linux/gpio.h>
+#include <bcm47xx_board.h>
+#include <bcm47xx.h>
+
+static void __init bcm47xx_workarounds_netgear_wnr3500l(void)
+{
+ /* Set GPIO 12 to 1 to pass power to the USB port */
+ gpio_set_value(12, 1);
+}
+
+void __init bcm47xx_workarounds(void)
+{
+ enum bcm47xx_board board = bcm47xx_board_get();
+
+ switch (board) {
+ case BCM47XX_BOARD_NETGEAR_WNR3500L:
+ bcm47xx_workarounds_netgear_wnr3500l();
+ break;
+ default:
+ /* No workaround(s) needed */
+ break;
+ }
+}

View File

@ -43,10 +43,10 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
static int __init bcm47xx_register_bus_complete(void)
{
switch (bcm47xx_bus_type) {
@@ -274,6 +283,7 @@ static int __init bcm47xx_register_bus_c
@@ -275,6 +284,7 @@ static int __init bcm47xx_register_bus_c
bcm47xx_buttons_register();
bcm47xx_leds_register();
bcm47xx_workarounds();
+ fixed_phy_add(PHY_POLL, 0, &bcm47xx_fixed_phy_status);
return 0;

View File

@ -7,7 +7,7 @@ out the configuration than the in kernel cfe config reader.
+++ b/arch/mips/bcm47xx/Makefile
@@ -6,3 +6,4 @@
obj-y += irq.o nvram.o prom.o serial.o setup.o time.o sprom.o
obj-y += board.o buttons.o leds.o
obj-y += board.o buttons.o leds.o workarounds.o
obj-y += gpio.o
+obj-y += cfe_env.o
--- /dev/null

View File

@ -42,9 +42,9 @@
static int __init bcm47xx_register_bus_complete(void)
{
switch (bcm47xx_bus_type) {
@@ -284,6 +312,7 @@ static int __init bcm47xx_register_bus_c
bcm47xx_buttons_register();
@@ -285,6 +313,7 @@ static int __init bcm47xx_register_bus_c
bcm47xx_leds_register();
bcm47xx_workarounds();
fixed_phy_add(PHY_POLL, 0, &bcm47xx_fixed_phy_status);
+ bcm47xx_register_gpio_watchdog();