valgrind: update to the latest version, fix musl support

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 42978
This commit is contained in:
Felix Fietkau 2014-10-19 22:35:27 +00:00
parent 939d0869cc
commit 35232039c0
4 changed files with 50 additions and 15 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=valgrind
PKG_VERSION:=3.8.1
PKG_VERSION:=3.10.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://valgrind.org/downloads/
PKG_MD5SUM:=288758010b271119a0ffc0183f1d6e38
PKG_MD5SUM:=7c311a72a20388aceced1aa5573ce970
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>

View File

@ -1,6 +1,6 @@
--- a/configure.in
+++ b/configure.in
@@ -260,7 +260,7 @@ case "${host_os}" in
--- a/configure.ac
+++ b/configure.ac
@@ -300,7 +300,7 @@ case "${host_os}" in
# Ok, this is linux. Check the kernel version
AC_MSG_CHECKING([for the kernel version])

View File

@ -1,10 +0,0 @@
--- a/coregrind/vgdb.c
+++ b/coregrind/vgdb.c
@@ -102,7 +102,6 @@ I_die_here : (PTRACEINVOKER) architectur
#include <sys/user.h>
#if defined(VGO_linux)
# include <sys/prctl.h>
-# include <linux/ptrace.h>
#endif
#endif

View File

@ -0,0 +1,45 @@
--- a/coregrind/vg_preloaded.c
+++ b/coregrind/vg_preloaded.c
@@ -56,7 +56,7 @@
void VG_NOTIFY_ON_LOAD(freeres)( void );
void VG_NOTIFY_ON_LOAD(freeres)( void )
{
-# if !defined(__UCLIBC__) \
+# if !defined(__UCLIBC__) && defined(__GLIBC__) \
&& !defined(VGPV_arm_linux_android) && !defined(VGPV_x86_linux_android) \
&& !defined(VGPV_mips32_linux_android)
extern void __libc_freeres(void);
--- a/include/pub_tool_redir.h
+++ b/include/pub_tool_redir.h
@@ -241,7 +241,7 @@
/* --- Soname of the standard C library. --- */
#if defined(VGO_linux)
-# define VG_Z_LIBC_SONAME libcZdsoZa // libc.so*
+# define VG_Z_LIBC_SONAME libcZdZa // libc.*
#elif defined(VGO_darwin) && (DARWIN_VERS <= DARWIN_10_6)
# define VG_Z_LIBC_SONAME libSystemZdZaZddylib // libSystem.*.dylib
@@ -273,7 +273,11 @@
/* --- Soname of the pthreads library. --- */
#if defined(VGO_linux)
+# if defined(__GLIBC__) || defined(__UCLIBC__)
# define VG_Z_LIBPTHREAD_SONAME libpthreadZdsoZd0 // libpthread.so.0
+# else
+# define VG_Z_LIBPTHREAD_SONAME libcZdZa // libc.*
+# endif
#elif defined(VGO_darwin)
# define VG_Z_LIBPTHREAD_SONAME libSystemZdZaZddylib // libSystem.*.dylib
#else
--- a/configure.ac
+++ b/configure.ac
@@ -1031,8 +1031,6 @@ case "${GLIBC_VERSION}" in
*)
AC_MSG_RESULT([unsupported version ${GLIBC_VERSION}])
- AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.19])
- AC_MSG_ERROR([or Darwin or Bionic libc])
;;
esac