fix build when arch != mipsel

SVN-Revision: 2038
This commit is contained in:
Nicolas Thill 2005-10-03 02:16:27 +00:00
parent cf690e07fe
commit 5d8dc20df2
2 changed files with 9 additions and 13 deletions

View File

@ -20,6 +20,13 @@ endif
include $(TOPDIR)/package/rules.mk
ifeq ($(LINUX_KARCH),i386)
KERNEL_C_OPTS:= -Os -mpreferred-stack-boundary=2 -march=i486 -fno-unit-at-a-time
endif
ifeq ($(LINUX_KARCH),mips)
KERNEL_C_OPTS:= -Os -G 0 -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
endif
$(eval $(call PKG_template,KMOD_ALSA,kmod-alsa,$(LINUX_VERSION)$(BOARD)+$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH),kernel-$(LINUX_VERSION)-$(BOARD) ($(KERNEL_RELEASE))))
$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
@ -35,7 +42,8 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
touch $@
$(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
c_opts="$(KERNEL_C_OPTS)"
touch $@
$(IPKG_KMOD_ALSA):

View File

@ -1,12 +0,0 @@
diff -rNu alsa-driver-1.0.9b/Makefile.conf.in alsa-driver-1.0.9b.new/Makefile.conf.in
--- alsa-driver-1.0.9b/Makefile.conf.in 2005-04-15 23:09:33.000000000 +1000
+++ alsa-driver-1.0.9b.new/Makefile.conf.in 2005-09-04 11:29:15.000000000 +1000
@@ -53,6 +53,8 @@
INCLUDE = -I$(TOPDIR)/include @EXTRA_INCLUDES@ @KERNEL_INC@
CFLAGS = $(MODFLAGS) $(INCLUDE) $(c_opts) -Wall -Wstrict-prototypes \
-fomit-frame-pointer -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common \
+ -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 \
+ -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap -mlong-calls \
-pipe -DALSA_BUILD -nostdinc -iwithprefix include
ifdef CONFIG_SND_MVERSION
CFLAGS += -DMODVERSIONS -include $(CONFIG_SND_KERNELDIR)/include/linux/modversions.h