ar71xx: refresh patches

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

SVN-Revision: 41615
This commit is contained in:
Gabor Juhos 2014-07-13 16:25:56 +00:00
parent d0ad8c00b6
commit 68871def8d
12 changed files with 33 additions and 36 deletions

View File

@ -170,7 +170,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
struct ath79_spi {
struct spi_bitbang bitbang;
u32 ioc_base;
@@ -69,6 +71,7 @@ static void ath79_spi_chipselect(struct
@@ -69,6 +71,7 @@ static void ath79_spi_chipselect(struct
{
struct ath79_spi *sp = ath79_spidev_to_sp(spi);
int cs_high = (spi->mode & SPI_CS_HIGH) ? is_active : !is_active;
@ -178,7 +178,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
if (is_active) {
/* set initial clock polarity */
@@ -80,20 +83,24 @@ static void ath79_spi_chipselect(struct
@@ -80,20 +83,24 @@ static void ath79_spi_chipselect(struct
ath79_spi_wr(sp, AR71XX_SPI_REG_IOC, sp->ioc_base);
}

View File

@ -84,7 +84,7 @@
mutex_unlock(&flash->lock);
return 0;
@@ -1022,6 +1045,12 @@ static int m25p_probe(struct spi_device
@@ -1022,6 +1045,12 @@ static int m25p_probe(struct spi_device
flash->mtd._unlock = m25p80_unlock;
}

View File

@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
@@ -1122,7 +1122,9 @@ static int m25p_probe(struct spi_device
@@ -1122,7 +1122,9 @@ static int m25p_probe(struct spi_device
/* partitions should match sector boundaries; and it may be good to
* use readonly partitions for writeprotected sectors (BP2..BP0).
*/

View File

@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
@@ -1072,6 +1072,7 @@ static int m25p_probe(struct spi_device
@@ -1072,6 +1072,7 @@ static int m25p_probe(struct spi_device
if (info->flags & M25P_NO_ERASE)
flash->mtd.flags |= MTD_NO_ERASE;

View File

@ -1,6 +1,6 @@
--- a/drivers/net/phy/phy.c
+++ b/drivers/net/phy/phy.c
@@ -1009,6 +1009,12 @@ static int phy_read_mmd_indirect(struct
@@ -1009,6 +1009,12 @@ static int phy_read_mmd_indirect(struct
return ret;
}

View File

@ -1,6 +1,6 @@
--- a/arch/mips/ath79/early_printk.c
+++ b/arch/mips/ath79/early_printk.c
@@ -56,6 +56,46 @@ static void prom_putchar_dummy(unsigned
@@ -56,6 +56,46 @@ static void prom_putchar_dummy(unsigned
/* nothing to do */
}

View File

@ -29,13 +29,11 @@
- u32 bootstrap;
+ void __iomem *phy_reg;
+ u32 t;
- bootstrap = ath79_reset_rr(AR934X_RESET_REG_BOOTSTRAP);
- if (bootstrap & AR934X_BOOTSTRAP_USB_MODE_DEVICE)
+
+ phy_reg = ioremap(base, 4);
+ if (!phy_reg)
return;
+ return;
+
+ t = ioread32(phy_reg);
+ t &= ~0xff;
+ t |= 0x58;
@ -43,12 +41,14 @@
+
+ iounmap(phy_reg);
+}
+
- bootstrap = ath79_reset_rr(AR934X_RESET_REG_BOOTSTRAP);
- if (bootstrap & AR934X_BOOTSTRAP_USB_MODE_DEVICE)
+static void ar934x_usb_reset_notifier(struct platform_device *pdev)
+{
+ if (pdev->id != -1)
+ return;
+
return;
+ enable_tx_tx_idp_violation_fix(0x18116c94);
+ dev_info(&pdev->dev, "TX-TX IDP fix enabled\n");
+}

View File

@ -50,7 +50,7 @@
#define PB44_GPIO_SW_RESET (PB44_GPIO_EXP_BASE + 6)
#define PB44_GPIO_SW_JUMP (PB44_GPIO_EXP_BASE + 8)
#define PB44_GPIO_LED_JUMP1 (PB44_GPIO_EXP_BASE + 9)
@@ -92,21 +117,66 @@ static struct ath79_spi_controller_data
@@ -92,21 +117,66 @@ static struct ath79_spi_controller_data
.cs_line = 0,
};

View File

@ -1,5 +1,5 @@
--- a/arch/mips/ath79/Kconfig 2014-05-21 20:25:24.801106234 +0000
+++ b/arch/mips/ath79/Kconfig 2014-05-21 20:28:20.489109814 +0000
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
@@ -462,6 +462,14 @@ config ATH79_MACH_RB2011
select ATH79_ROUTERBOOT
select RLE_DECOMPRESS
@ -15,8 +15,8 @@
config ATH79_MACH_WNDAP360
bool "NETGEAR WNDAP360 board support"
select SOC_AR71XX
--- a/arch/mips/ath79/machtypes.h 2014-05-21 20:25:24.801106234 +0000
+++ b/arch/mips/ath79/machtypes.h 2014-05-21 20:30:04.829111865 +0000
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
@@ -93,6 +93,8 @@ enum ath79_mach_type {
ATH79_MACH_RB_2011G, /* Mikrotik RouterBOARD 2011UAS-2HnD */
ATH79_MACH_RB_2011L, /* Mikrotik RouterBOARD 2011L */
@ -26,8 +26,8 @@
ATH79_MACH_RW2458N, /* Redwave RW2458N */
ATH79_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
ATH79_MACH_TEW_673GRU, /* TRENDnet TEW-673GRU */
--- a/arch/mips/ath79/Makefile 2014-05-21 20:25:24.801106234 +0000
+++ b/arch/mips/ath79/Makefile 2014-05-21 20:31:37.169113830 +0000
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
@@ -85,6 +85,7 @@ obj-$(CONFIG_ATH79_MACH_RB750) += mach-
obj-$(CONFIG_ATH79_MACH_RB91X) += mach-rb91x.o
obj-$(CONFIG_ATH79_MACH_RB95X) += mach-rb95x.o

View File

@ -1,11 +1,9 @@
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
@@ -647,7 +647,17 @@ config ATH79_MACH_TL_WAX50RE
select ATH79_DEV_LEDS_GPIO
@@ -656,6 +656,16 @@ config ATH79_MACH_TL_WAX50RE
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
-
+
+config ATH79_MACH_TL_WA830RE_V2
+ bool "TP-LINK TL-WA830RE v2 support"
+ select SOC_AR934X
@ -21,7 +19,7 @@
select SOC_AR724X
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
@@ -95,6 +95,7 @@ obj-$(CONFIG_ATH79_MACH_TL_MR13U) += mac
@@ -96,6 +96,7 @@ obj-$(CONFIG_ATH79_MACH_TL_MR13U) += mac
obj-$(CONFIG_ATH79_MACH_TL_MR3020) += mach-tl-mr3020.o
obj-$(CONFIG_ATH79_MACH_TL_MR3X20) += mach-tl-mr3x20.o
obj-$(CONFIG_ATH79_MACH_TL_WAX50RE) += mach-tl-wax50re.o
@ -31,12 +29,11 @@
obj-$(CONFIG_ATH79_MACH_TL_WDR3500) += mach-tl-wdr3500.o
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
@@ -112,6 +112,7 @@ enum ath79_mach_type {
@@ -114,6 +114,7 @@ enum ath79_mach_type {
ATH79_MACH_TL_WA7510N_V1, /* TP-LINK TL-WA7510N v1*/
ATH79_MACH_TL_WA850RE, /* TP-LINK TL-WA850RE */
ATH79_MACH_TL_WA801ND_V2, /* TP-LINK TL-WA801ND v2 */
+ ATH79_MACH_TL_WA830RE_V2, /* TP-LINK TL-WA830RE v2 */
ATH79_MACH_TL_WA901ND, /* TP-LINK TL-WA901ND */
ATH79_MACH_TL_WA901ND_V2, /* TP-LINK TL-WA901ND v2 */
ATH79_MACH_TL_WA901ND_V3, /* TP-LINK TL-WA901ND v3
ATH79_MACH_TL_WA901ND_V3, /* TP-LINK TL-WA901ND v3 */

View File

@ -1,6 +1,6 @@
--- a/arch/mips/ath79/machtypes.h 2014-07-13 10:00:11.952353943 +0200
+++ b/arch/mips/ath79/machtypes.h 2014-07-13 10:00:25.312354497 +0200
@@ -113,6 +113,7 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
@@ -113,6 +113,7 @@ enum ath79_mach_type {
ATH79_MACH_TL_WA750RE, /* TP-LINK TL-WA750RE */
ATH79_MACH_TL_WA7510N_V1, /* TP-LINK TL-WA7510N v1*/
ATH79_MACH_TL_WA850RE, /* TP-LINK TL-WA850RE */

View File

@ -229,7 +229,7 @@
#include <asm/uaccess.h>
#include <linux/proc_fs.h>
@@ -763,10 +764,10 @@ static void tcp_v6_send_response(struct
@@ -763,10 +764,10 @@ static void tcp_v6_send_response(struct
topt = (__be32 *)(t1 + 1);
if (tsecr) {
@ -662,7 +662,7 @@
#include <linux/netdevice.h>
--- a/include/net/inet_ecn.h
+++ b/include/net/inet_ecn.h
@@ -115,13 +115,13 @@ static inline int IP6_ECN_set_ce(struct
@@ -115,13 +115,13 @@ static inline int IP6_ECN_set_ce(struct
{
if (INET_ECN_is_not_ect(ipv6_get_dsfield(iph)))
return 0;
@ -855,7 +855,7 @@
ptr = ip6hoff + sizeof(struct ipv6hdr);
--- a/net/xfrm/xfrm_input.c
+++ b/net/xfrm/xfrm_input.c
@@ -77,8 +77,8 @@ int xfrm_parse_spi(struct sk_buff *skb,
@@ -77,8 +77,8 @@ int xfrm_parse_spi(struct sk_buff *skb,
if (!pskb_may_pull(skb, hlen))
return -EINVAL;