libiconv-full: update to version 1.16

- Removed following patches:
100-strip_charsets.patch - makes the full variant slim.
101-autotools.patch - this one fails to apply because it was backported
from newer versions for 1.11.1.
103-configure_ac_fix.patch - backported from newer versions
200-work-with-libtool2.patch - is not needed anymore, it is done
differently in upstream
300-fortify-source-compat.patch - these files are not there anymore

- TVHeadend requires working iconv library e.g. transliteration to ASCII
and this does not work with libiconv-full currently.

There is a simple test, which requires to install iconv package.

Before applying this update:
root@turris:/# echo ŽluťoučkýKůň | iconv -t ASCII//TRANSLIT//IGNORE
luoukK

After applying this update:
root@turris:~# echo ŽluťoučkýKůň | iconv -t ASCII//TRANSLIT//IGNORE
Zlutouck'yKun

- Makefile changes:
Use HTTPS for their website
Fixed deprecated SPDX License Identifier
Move PKG_MAINTAINER above PKG_LICENSE

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Tested-by: Rosen Penev <rosenp@gmail.com> [malta]
This commit is contained in:
Josef Schlehofer 2020-07-20 15:47:31 +02:00 committed by Paul Spooren
parent 3f567d8452
commit 75063b941b
6 changed files with 7 additions and 29530 deletions

View File

@ -8,16 +8,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libiconv-full
PKG_VERSION:=1.11.1
PKG_RELEASE:=4
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
PKG_VERSION:=1.16
PKG_RELEASE:=1
PKG_SOURCE:=libiconv-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/libiconv
PKG_HASH:=e78c347a1a0cb15f2648519e9799151f4b4a934b61ad9ee7424478efe2b8257f
PKG_HASH:=e6a1b1b589654277ee790cce3734f07876ac4ccfaecbee8afa0b649cf529cc04
PKG_BUILD_DIR:=$(BUILD_DIR)/libiconv-$(PKG_VERSION)
PKG_LICENSE:=LGPL-2.0
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
PKG_LICENSE:=LGPL-2.1-or-later
PKG_LICENSE_FILES:=COPYING.LIB
PKG_FIXUP:=patch-libtool
@ -25,7 +25,7 @@ PKG_FIXUP:=patch-libtool
include $(INCLUDE_DIR)/package.mk
define Package/libiconv-full/Default
URL:=http://www.gnu.org/software/libiconv/
URL:=https://www.gnu.org/software/libiconv/
TITLE:=Character set conversion
endef

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

View File

@ -1,31 +0,0 @@
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,2 @@
+ACLOCAL_AMFLAGS = -I m4
+SUBDIRS = .
--- /dev/null
+++ b/libcharset/Makefile.am
@@ -0,0 +1 @@
+ACLOCAL_AMFLAGS = -I m4
--- a/configure.ac
+++ b/configure.ac
@@ -54,7 +54,7 @@ AC_ISC_POSIX
dnl checks for installer options
-AC_RELOCATABLE
+gl_RELOCATABLE
AC_ARG_ENABLE([extra-encodings],
[AC_HELP_STRING([--enable-extra-encodings],
--- a/libcharset/configure.ac
+++ b/libcharset/configure.ac
@@ -41,7 +41,7 @@ AC_CANONICAL_HOST
dnl checks for installer options
-AC_RELOCATABLE_LIBRARY
+gl_RELOCATABLE_LIBRARY
dnl checks for programs

View File

@ -1,17 +0,0 @@
Make iconv 1.11.x link correctly with libtool2 - argument "-Xcompiler" ensures "-shared" is passed to $(CC) when used as linker. Otherwise $(CC) tries to create an executable and fails while looking for a main()-function
diff -ruN libiconv-1.11.1/lib/Makefile.in libiconv-1.11.1.mod/lib/Makefile.in
--- libiconv-1.11.1/lib/Makefile.in 2006-07-14 15:18:42.000000000 +0200
+++ libiconv-1.11.1.mod/lib/Makefile.in 2010-12-01 20:47:57.000000000 +0100
@@ -70,9 +70,9 @@
preloadable_libiconv_linux.so : $(SOURCES)
if test -n "@GCC@"; then \
- $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(INCLUDES) $(CFLAGS) $(CPPFLAGS) $(DEFS) -fPIC -DPIC -DLIBICONV_PLUG $(SOURCES) -shared -o preloadable_libiconv_linux.so; \
+ $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(INCLUDES) $(CFLAGS) $(CPPFLAGS) $(DEFS) -fPIC -DPIC -DLIBICONV_PLUG $(SOURCES) -Xcompiler -shared -o preloadable_libiconv_linux.so; \
else \
- $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(INCLUDES) $(CFLAGS) $(CPPFLAGS) $(DEFS) -KPIC -DPIC -DLIBICONV_PLUG $(SOURCES) -shared -o preloadable_libiconv_linux.so; \
+ $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(INCLUDES) $(CFLAGS) $(CPPFLAGS) $(DEFS) -KPIC -DPIC -DLIBICONV_PLUG $(SOURCES) -Xcompiler -shared -o preloadable_libiconv_linux.so; \
fi
preloadable_libiconv_solaris.so : $(SOURCES)

View File

@ -1,23 +0,0 @@
--- a/m4/canonicalize.m4
+++ b/m4/canonicalize.m4
@@ -11,8 +11,6 @@ AC_DEFUN([gl_CANONICALIZE],
AC_CHECK_FUNCS(canonicalize_file_name)
if test $ac_cv_func_canonicalize_file_name = no; then
AC_LIBOBJ(canonicalize)
- AC_DEFINE([realpath], [rpl_realpath],
- [Define to a replacement function name for realpath().])
gl_PREREQ_CANONICALIZE
fi
])
--- a/configure
+++ b/configure
@@ -35532,9 +35532,6 @@ done
if test $ac_cv_func_canonicalize_file_name = no; then
SRCLIBOBJS="$SRCLIBOBJS canonicalize.$ac_objext"
-cat >>confdefs.h <<\_ACEOF
-#define realpath rpl_realpath
-_ACEOF