add -funit-at-a-time in trunk/ as well

SVN-Revision: 2291
This commit is contained in:
Felix Fietkau 2005-10-23 21:06:51 +00:00
parent 3332476df6
commit 7d36633493
4 changed files with 39 additions and 3 deletions

View File

@ -0,0 +1,24 @@
--- linux-2.4.30/Makefile 2005-10-23 20:52:56.813948000 +0200
+++ linux.dev/Makefile 2005-10-23 20:53:12.482927250 +0200
@@ -89,6 +89,8 @@
# standard CFLAGS
#
+check_gcc = $(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi)
+
CPPFLAGS := -D__KERNEL__ -I$(HPATH)
CFLAGS := $(CPPFLAGS) -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
@@ -100,6 +102,12 @@
endif
AFLAGS := -D__ASSEMBLY__ $(CPPFLAGS)
+CFLAGS += $(call check_gcc, -funit-at-a-time,)
+
+
+
+
+
#
# ROOT_DEV specifies the default root-device when making the image.
# This can be either FLOPPY, CURRENT, /dev/xxxx or empty, in which case

View File

@ -0,0 +1,12 @@
--- linux-2.6.12.5/Makefile.old 2005-10-23 22:56:29.017270000 +0200
+++ linux-2.6.12.5/Makefile 2005-10-23 22:57:23.226138500 +0200
@@ -533,6 +533,9 @@
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
+# improve gcc optimization
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)

View File

@ -24,5 +24,5 @@ config BR2_SOFT_FLOAT
config BR2_TARGET_OPTIMIZATION
string
default "-Os -pipe -mips32 -mtune=mips32"
default "-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time"

View File

@ -37,8 +37,8 @@ config BR2_SOFT_FLOAT
config BR2_TARGET_OPTIMIZATION
string "Target Optimizations"
default "-Os -pipe -march=i486" if BR2_i386
default "-Os -pipe -mips32 -mtune=mips32" if BR2_mipsel
default "-Os -pipe -march=i486 -funit-at-a-time" if BR2_i386
default "-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time" if BR2_mipsel
help
Optimizations to use when building for the target host.