update to new version, fixes bug #153

SVN-Revision: 2767
This commit is contained in:
Waldemar Brodkorb 2005-12-25 02:10:14 +00:00
parent d7aafe7f75
commit 97e2462e1f
3 changed files with 21 additions and 22 deletions

View File

@ -4,9 +4,9 @@ include $(TOPDIR)/rules.mk
include ../../rules.mk
PKG_NAME:=spca5xx
PKG_VERSION:=20051105
PKG_VERSION:=20051212
PKG_RELEASE:=1
PKG_MD5SUM:=7d2e84c3d3880728fefd5644713ba0ca
PKG_MD5SUM:=f8212aa6f5e412201eefd328c3608c8d
PKG_SOURCE_URL:=http://mxhaard.free.fr/spca50x/Download/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz

View File

@ -1,4 +1,5 @@
Package: kmod-spca5xx
Priority: optional
Section: sys
Depends: kmod-videodev, kmod-usb-core
Description: Kernel driver for SPCA5XX based USB cameras

View File

@ -1,6 +1,6 @@
diff -ruN spca5xx-20051105-old/Makefile spca5xx-20051105-new/Makefile
--- spca5xx-20051105-old/Makefile 2005-11-05 19:18:26.000000000 +0100
+++ spca5xx-20051105-new/Makefile 2005-12-09 10:34:47.000000000 +0100
diff -Nur spca5xx-20051212/Makefile spca5xx-20051212.patched/Makefile
--- spca5xx-20051212/Makefile 2005-12-10 17:05:51.000000000 +0100
+++ spca5xx-20051212.patched/Makefile 2005-12-25 02:41:29.910720750 +0100
@@ -33,7 +33,9 @@
DEFINES += -DCONFIG_USB_SPCA5XX_MODULE=1 -DMODULE -D__KERNEL__
DEFINES += -DVID_HARDWARE_SPCA5XX=0xFF -DSPCA5XX_VERSION=\"$(VERSION)\"
@ -12,7 +12,7 @@ diff -ruN spca5xx-20051105-old/Makefile spca5xx-20051105-new/Makefile
ifneq ($(KERNELRELEASE),) # We were called by kbuild
CFLAGS += $(DEFINES)
@@ -68,158 +70,19 @@
@@ -68,152 +70,16 @@
else # kernel version test
@ -26,11 +26,9 @@ diff -ruN spca5xx-20051105-old/Makefile spca5xx-20051105-new/Makefile
-# This makefile will build the spca50x driver module external to the kernel
-# source tree. It makes it easier to swap kernels.
-
+EXTRA_CFLAGS += $(DEFINES)
-
-KERNEL_VERSION = `uname -r`
+spca5xx-objs := drivers/usb/spca5xx.o drivers/usb/spcadecoder.o
-
-###
-# Location of the header files (most importantly the config files)
-# for the kernel you want to build the module against.
@ -44,15 +42,12 @@ diff -ruN spca5xx-20051105-old/Makefile spca5xx-20051105-new/Makefile
-ifneq ($(strip $(shell grep 'define CONFIG_MODVERSIONS 1' $(KERNEL_ACFILE))),)
- DEFINES += -DMODVERSIONS -include $(KERNEL_MODVERSIONSFILE)
-endif
+obj-m += spca5xx.o
+obj-y := $(spca5xx-objs)
-
-# Detect SMP support
-ifneq ($(strip $(shell grep 'define CONFIG_SMP 1' $(KERNEL_ACFILE))),)
- DEFINES += -D__SMP__ -DSMP
-endif
+O_TARGET := $(obj-m)
-
-# Setup the tools
-CC = gcc
-LD = ld
@ -77,8 +72,6 @@ diff -ruN spca5xx-20051105-old/Makefile spca5xx-20051105-new/Makefile
- drivers/usb/Config.in \
- drivers/usb/spcadecoder.c \
- drivers/usb/spcadecoder.h \
- drivers/usb/jpeg_header.h \
- drivers/usb/jpeg_qtables.h \
- drivers/usb/spcagamma.h \
- drivers/usb/spcaCompat.h \
- drivers/usb/spcausb.h \
@ -168,12 +161,17 @@ diff -ruN spca5xx-20051105-old/Makefile spca5xx-20051105-new/Makefile
-
-drivers/usb/spcadecoder.o: drivers/usb/spcadecoder.h \
- drivers/usb/spcagamma.h \
- drivers/usb/jpeg_header.h
-
+EXTRA_CFLAGS += $(DEFINES)
+
+spca5xx-objs := drivers/usb/spca5xx.o drivers/usb/spcadecoder.o
+
+obj-m += spca5xx.o
+obj-y := $(spca5xx-objs)
+
+O_TARGET := $(obj-m)
+
+-include $(TOPDIR)/Rules.make
endif # End kernel version test
-
##############################################################################
# OTHER TARGETS
##############################################################################