ar71xx: Add Netgear WNR2000v3 support

Network connectivity works fine (LAN and WAN).
For GPIOs, only pwr led and the green wan leds are supported for now.

Signed-off-by: Mathieu Olivari <mathieu.olivari@gmail.com>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

SVN-Revision: 36459
This commit is contained in:
Gabor Juhos 2013-04-26 17:00:52 +00:00
parent 183e2af1c7
commit 9b3c0d11a2
3 changed files with 130 additions and 0 deletions

View File

@ -85,6 +85,7 @@ CONFIG_ATH79_MACH_WLAE_AG300N=y
CONFIG_ATH79_MACH_WNDR3700=y
CONFIG_ATH79_MACH_WNDR4300=y
CONFIG_ATH79_MACH_WNR2000=y
CONFIG_ATH79_MACH_WNR2000_V3=y
CONFIG_ATH79_MACH_WP543=y
CONFIG_ATH79_MACH_WPE72=y
CONFIG_ATH79_MACH_WRT160NL=y

View File

@ -0,0 +1,91 @@
/*
* NETGEAR WNR2000v3 board support
*
* Copytight (C) 2013 Mathieu Olivari <mathieu.olivari@gmail.com>
* Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
* Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
* Copyright (C) 2008-2009 Andy Boyett <agb@openwrt.org>
*
* This program is free software; you can redistribute it and/or modify it
* under the terms of the GNU General Public License version 2 as published
* by the Free Software Foundation.
*/
#include <linux/mtd/mtd.h>
#include <linux/mtd/partitions.h>
#include <asm/mach-ath79/ath79.h>
#include "dev-ap9x-pci.h"
#include "dev-eth.h"
#include "dev-gpio-buttons.h"
#include "dev-leds-gpio.h"
#include "dev-m25p80.h"
#include "machtypes.h"
#define WNR2000V3_GPIO_LED_WAN_GREEN 0
#define WNR2000V3_GPIO_LED_LAN1_AMBER 1
#define WNR2000V3_GPIO_LED_LAN4_AMBER 12
#define WNR2000V3_GPIO_LED_PWR_GREEN 14
#define WNR2000V3_GPIO_BTN_WPS 11
#define WNR2000V3_KEYS_POLL_INTERVAL 20 /* msecs */
#define WNR2000V3_KEYS_DEBOUNCE_INTERVAL (3 * WNR2000V3_KEYS_POLL_INTERVAL)
#define WNR2000V3_MAC0_OFFSET 0
#define WNR2000V3_MAC1_OFFSET 6
#define WNR2000V3_PCIE_CALDATA_OFFSET 0x1000
static struct gpio_led wnr2000v3_leds_gpio[] __initdata = {
{
.name = "wnr2000v3:green:power",
.gpio = WNR2000V3_GPIO_LED_PWR_GREEN,
.active_low = 1,
}, {
.name = "wnr2000v3:green:wan",
.gpio = WNR2000V3_GPIO_LED_WAN_GREEN,
.active_low = 1,
}
};
static struct gpio_keys_button wnr2000v3_gpio_keys[] __initdata = {
{
.desc = "wps",
.type = EV_KEY,
.code = KEY_WPS_BUTTON,
.debounce_interval = WNR2000V3_KEYS_DEBOUNCE_INTERVAL,
.gpio = WNR2000V3_GPIO_BTN_WPS,
}
};
static void __init wnr2000v3_setup(void)
{
u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
ath79_register_mdio(0, 0x0);
ath79_init_mac(ath79_eth0_data.mac_addr, art+WNR2000V3_MAC0_OFFSET, 0);
ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RMII;
ath79_eth0_data.speed = SPEED_100;
ath79_eth0_data.duplex = DUPLEX_FULL;
ath79_init_mac(ath79_eth1_data.mac_addr, art+WNR2000V3_MAC1_OFFSET, 0);
ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_RMII;
ath79_eth1_data.phy_mask = 0x10;
ath79_register_eth(0);
ath79_register_eth(1);
ath79_register_m25p80(NULL);
ath79_register_leds_gpio(-1, ARRAY_SIZE(wnr2000v3_leds_gpio),
wnr2000v3_leds_gpio);
ath79_register_gpio_keys_polled(-1, WNR2000V3_KEYS_POLL_INTERVAL,
ARRAY_SIZE(wnr2000v3_gpio_keys),
wnr2000v3_gpio_keys);
ap91_pci_init(art + WNR2000V3_PCIE_CALDATA_OFFSET, NULL);
}
MIPS_MACHINE(ATH79_MACH_WNR2000_V3, "WNR2000V3", "NETGEAR WNR2000 V3", wnr2000v3_setup);

View File

@ -0,0 +1,38 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
@@ -119,6 +119,7 @@ enum ath79_mach_type {
ATH79_MACH_WNDR3700, /* NETGEAR WNDR3700/WNDR3800/WNDRMAC */
ATH79_MACH_WNDR4300, /* NETGEAR WNDR4300 */
ATH79_MACH_WNR2000, /* NETGEAR WNR2000 */
+ ATH79_MACH_WNR2000_V3, /* NETGEAR WNR2000 v3 */
ATH79_MACH_WP543, /* Compex WP543 */
ATH79_MACH_WPE72, /* Compex WPE72 */
ATH79_MACH_WRT160NL, /* Linksys WRT160NL */
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
@@ -408,6 +408,15 @@ config ATH79_MACH_WNR2000
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
+config ATH79_MACH_WNR2000_V3
+ bool "NETGEAR WNR2000 V3 board support"
+ select SOC_AR724X
+ select ATH79_DEV_AP9X_PCI if PCI
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+
config ATH79_MACH_OM2P
bool "OpenMesh OM2P board support"
select SOC_AR724X
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
@@ -100,6 +100,7 @@ obj-$(CONFIG_ATH79_MACH_WLAE_AG300N) +=
obj-$(CONFIG_ATH79_MACH_WNDR3700) += mach-wndr3700.o
obj-$(CONFIG_ATH79_MACH_WNDR4300) += mach-wndr4300.o
obj-$(CONFIG_ATH79_MACH_WNR2000) += mach-wnr2000.o
+obj-$(CONFIG_ATH79_MACH_WNR2000_V3) += mach-wnr2000-v3.o
obj-$(CONFIG_ATH79_MACH_WP543) += mach-wp543.o
obj-$(CONFIG_ATH79_MACH_WPE72) += mach-wpe72.o
obj-$(CONFIG_ATH79_MACH_WRT160NL) += mach-wrt160nl.o