refresh patches

SVN-Revision: 17738
This commit is contained in:
Hauke Mehrtens 2009-09-26 13:29:13 +00:00
parent f9b2e12b61
commit a2698ec77c
8 changed files with 162 additions and 162 deletions

View File

@ -23,7 +23,7 @@
/* The Mellanox Tavor device gives false positive parity errors /* The Mellanox Tavor device gives false positive parity errors
* Mark this device with a broken_parity_status, to allow * Mark this device with a broken_parity_status, to allow
* PCI scanning code to "skip" this now blacklisted device. * PCI scanning code to "skip" this now blacklisted device.
@@ -1859,7 +1860,9 @@ static void __devinit fixup_rev1_53c810( @@ -1860,7 +1861,9 @@ static void __devinit fixup_rev1_53c810(
} }
} }
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810); DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810);
@ -33,7 +33,7 @@
/* Enable 1k I/O space granularity on the Intel P64H2 */ /* Enable 1k I/O space granularity on the Intel P64H2 */
static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev) static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
{ {
@@ -2463,6 +2466,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I @@ -2466,6 +2469,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x10e7, quirk_i82576_sriov); DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x10e7, quirk_i82576_sriov);
#endif /* CONFIG_PCI_IOV */ #endif /* CONFIG_PCI_IOV */

View File

@ -23,7 +23,7 @@
/* The Mellanox Tavor device gives false positive parity errors /* The Mellanox Tavor device gives false positive parity errors
* Mark this device with a broken_parity_status, to allow * Mark this device with a broken_parity_status, to allow
* PCI scanning code to "skip" this now blacklisted device. * PCI scanning code to "skip" this now blacklisted device.
@@ -1866,7 +1867,9 @@ static void __devinit fixup_rev1_53c810( @@ -1867,7 +1868,9 @@ static void __devinit fixup_rev1_53c810(
} }
} }
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810); DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810);
@ -33,8 +33,8 @@
/* Enable 1k I/O space granularity on the Intel P64H2 */ /* Enable 1k I/O space granularity on the Intel P64H2 */
static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev) static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
{ {
@@ -2494,6 +2497,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I @@ -2498,6 +2501,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x150a, quirk_i82576_sriov); DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x150d, quirk_i82576_sriov);
#endif /* CONFIG_PCI_IOV */ #endif /* CONFIG_PCI_IOV */
+#endif /* !CONFIG_PCI_DISABLE_COMMON_QUIRKS */ +#endif /* !CONFIG_PCI_DISABLE_COMMON_QUIRKS */

View File

@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/block2mtd.c --- a/drivers/mtd/devices/block2mtd.c
+++ b/drivers/mtd/devices/block2mtd.c +++ b/drivers/mtd/devices/block2mtd.c
@@ -268,6 +268,7 @@ @@ -268,6 +268,7 @@ static int _open_bdev(struct block2mtd_d
/* We might not have rootfs mounted at this point. Try /* We might not have rootfs mounted at this point. Try
to resolve the device name by other means. */ to resolve the device name by other means. */

View File

@ -1,6 +1,6 @@
--- a/fs/namespace.c --- a/fs/namespace.c
+++ b/fs/namespace.c +++ b/fs/namespace.c
@@ -1550,7 +1550,7 @@ @@ -1550,7 +1550,7 @@ static int do_loopback(struct path *path
if (!mnt) if (!mnt)
goto out; goto out;

View File

@ -1,6 +1,6 @@
--- a/include/linux/union.h --- a/include/linux/union.h
+++ b/include/linux/union.h +++ b/include/linux/union.h
@@ -77,7 +77,7 @@ @@ -77,7 +77,7 @@ extern int union_permission(struct path
#define __union_copyup(x, y, z) ({ BUG(); (0); }) #define __union_copyup(x, y, z) ({ BUG(); (0); })
#define union_copyup(x, y) ({ (0); }) #define union_copyup(x, y) ({ (0); })
#define union_copyup_dir(x) ({ BUG(); (0); }) #define union_copyup_dir(x) ({ BUG(); (0); })

View File

@ -1,6 +1,6 @@
--- a/fs/Kconfig --- a/fs/Kconfig
+++ b/fs/Kconfig +++ b/fs/Kconfig
@@ -188,6 +188,7 @@ source "fs/sysv/Kconfig" @@ -196,6 +196,7 @@ source "fs/sysv/Kconfig"
source "fs/ufs/Kconfig" source "fs/ufs/Kconfig"
source "fs/exofs/Kconfig" source "fs/exofs/Kconfig"
source "fs/nilfs2/Kconfig" source "fs/nilfs2/Kconfig"
@ -10,7 +10,7 @@
--- a/fs/Makefile --- a/fs/Makefile
+++ b/fs/Makefile +++ b/fs/Makefile
@@ -125,3 +125,4 @@ obj-$(CONFIG_OCFS2_FS) += ocfs2/ @@ -126,3 +126,4 @@ obj-$(CONFIG_OCFS2_FS) += ocfs2/
obj-$(CONFIG_BTRFS_FS) += btrfs/ obj-$(CONFIG_BTRFS_FS) += btrfs/
obj-$(CONFIG_GFS2_FS) += gfs2/ obj-$(CONFIG_GFS2_FS) += gfs2/
obj-$(CONFIG_EXOFS_FS) += exofs/ obj-$(CONFIG_EXOFS_FS) += exofs/

View File

@ -1,6 +1,6 @@
--- a/mm/shmem.c --- a/mm/shmem.c
+++ b/mm/shmem.c +++ b/mm/shmem.c
@@ -2769,6 +2769,16 @@ @@ -2769,6 +2769,16 @@ int shmem_unuse(swp_entry_t entry, struc
/* common code */ /* common code */
@ -17,7 +17,7 @@
/** /**
* shmem_file_setup - get an unlinked file living in tmpfs * shmem_file_setup - get an unlinked file living in tmpfs
* @name: name for dentry (to be seen in /proc/<pid>/maps * @name: name for dentry (to be seen in /proc/<pid>/maps
@@ -2848,10 +2858,7 @@ @@ -2848,10 +2858,7 @@ int shmem_zero_setup(struct vm_area_stru
if (IS_ERR(file)) if (IS_ERR(file))
return PTR_ERR(file); return PTR_ERR(file);
@ -31,7 +31,7 @@
--- a/fs/file.c --- a/fs/file.c
+++ b/fs/file.c +++ b/fs/file.c
@@ -270,6 +270,7 @@ @@ -270,6 +270,7 @@ int expand_files(struct files_struct *fi
/* All good, so we try */ /* All good, so we try */
return expand_fdtable(files, nr); return expand_fdtable(files, nr);
} }
@ -41,7 +41,7 @@
{ {
--- a/kernel/exit.c --- a/kernel/exit.c
+++ b/kernel/exit.c +++ b/kernel/exit.c
@@ -507,6 +507,7 @@ @@ -507,6 +507,7 @@ struct files_struct *get_files_struct(st
return files; return files;
} }
@ -49,7 +49,7 @@
void put_files_struct(struct files_struct *files) void put_files_struct(struct files_struct *files)
{ {
@@ -526,6 +527,7 @@ @@ -526,6 +527,7 @@ void put_files_struct(struct files_struc
free_fdtable(fdt); free_fdtable(fdt);
} }
} }
@ -59,7 +59,7 @@
{ {
--- a/kernel/fork.c --- a/kernel/fork.c
+++ b/kernel/fork.c +++ b/kernel/fork.c
@@ -159,6 +159,7 @@ @@ -159,6 +159,7 @@ void __put_task_struct(struct task_struc
if (!profile_handoff_task(tsk)) if (!profile_handoff_task(tsk))
free_task(tsk); free_task(tsk);
} }
@ -69,7 +69,7 @@
* macro override instead of weak attribute alias, to workaround * macro override instead of weak attribute alias, to workaround
--- a/kernel/sched.c --- a/kernel/sched.c
+++ b/kernel/sched.c +++ b/kernel/sched.c
@@ -5981,6 +5981,7 @@ @@ -5981,6 +5981,7 @@ int can_nice(const struct task_struct *p
return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur || return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
capable(CAP_SYS_NICE)); capable(CAP_SYS_NICE));
} }
@ -79,7 +79,7 @@
--- a/mm/memory.c --- a/mm/memory.c
+++ b/mm/memory.c +++ b/mm/memory.c
@@ -1064,6 +1064,7 @@ @@ -1064,6 +1064,7 @@ unsigned long zap_page_range(struct vm_a
tlb_finish_mmu(tlb, address, end); tlb_finish_mmu(tlb, address, end);
return end; return end;
} }
@ -87,7 +87,7 @@
/** /**
* zap_vma_ptes - remove ptes mapping the vma * zap_vma_ptes - remove ptes mapping the vma
@@ -2490,6 +2491,7 @@ @@ -2490,6 +2491,7 @@ int vmtruncate_range(struct inode *inode
return 0; return 0;
} }
@ -97,7 +97,7 @@
* We enter with non-exclusive mmap_sem (to exclude vma changes, * We enter with non-exclusive mmap_sem (to exclude vma changes,
--- a/mm/vmalloc.c --- a/mm/vmalloc.c
+++ b/mm/vmalloc.c +++ b/mm/vmalloc.c
@@ -1101,6 +1101,7 @@ @@ -1101,6 +1101,7 @@ void unmap_kernel_range(unsigned long ad
vunmap_page_range(addr, end); vunmap_page_range(addr, end);
flush_tlb_kernel_range(addr, end); flush_tlb_kernel_range(addr, end);
} }
@ -105,7 +105,7 @@
int map_vm_area(struct vm_struct *area, pgprot_t prot, struct page ***pages) int map_vm_area(struct vm_struct *area, pgprot_t prot, struct page ***pages)
{ {
@@ -1214,6 +1215,7 @@ @@ -1214,6 +1215,7 @@ struct vm_struct *get_vm_area(unsigned l
return __get_vm_area_node(size, flags, VMALLOC_START, VMALLOC_END, return __get_vm_area_node(size, flags, VMALLOC_START, VMALLOC_END,
-1, GFP_KERNEL, __builtin_return_address(0)); -1, GFP_KERNEL, __builtin_return_address(0));
} }
@ -115,7 +115,7 @@
void *caller) void *caller)
--- a/include/linux/mm.h --- a/include/linux/mm.h
+++ b/include/linux/mm.h +++ b/include/linux/mm.h
@@ -711,6 +711,7 @@ @@ -711,6 +711,7 @@ static inline int shmem_lock(struct file
#endif #endif
struct file *shmem_file_setup(const char *name, loff_t size, unsigned long flags); struct file *shmem_file_setup(const char *name, loff_t size, unsigned long flags);
@ -125,7 +125,7 @@
#ifndef CONFIG_MMU #ifndef CONFIG_MMU
--- a/kernel/signal.c --- a/kernel/signal.c
+++ b/kernel/signal.c +++ b/kernel/signal.c
@@ -1061,6 +1061,7 @@ @@ -1061,6 +1061,7 @@ struct sighand_struct *lock_task_sighand
return sighand; return sighand;
} }