add a load of fixes from whiterussian to head

SVN-Revision: 1410
This commit is contained in:
Felix Fietkau 2005-07-11 20:26:57 +00:00
parent f137e42da7
commit a47f2a3dff
10 changed files with 139 additions and 67 deletions

View File

@ -4,4 +4,4 @@ Section: apps
Maintainer: Waldemar Brodkorb <wbx@dass-it.de> Maintainer: Waldemar Brodkorb <wbx@dass-it.de>
Source: buildroot internal Source: buildroot internal
Description: lcd software Description: lcd software
Depends: ncurses Depends: libncurses

View File

@ -50,7 +50,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
--disable-java \ --disable-java \
--enable-cxx \ --enable-cxx \
--disable-posixmutexes \ --disable-posixmutexes \
--enable-uimutexes \ --disable-uimutexes \
--disable-tcl \ --disable-tcl \
--disable-rpc \ --disable-rpc \
--enable-compat185 \ --enable-compat185 \

View File

@ -25,7 +25,48 @@ include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,LIBNCURSES,libncurses,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH))) $(eval $(call PKG_template,LIBNCURSES,libncurses,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.prepared
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
./configure \
--target=$(GNU_HOST_NAME) \
--host=$(GNU_HOST_NAME) \
--build=$(GNU_HOST_NAME) \
--program-prefix="" \
--program-suffix="" \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \
--datadir=/usr/share \
--includedir=/usr/include \
--infodir=/usr/share/info \
--libdir=/usr/lib \
--libexecdir=/usr/lib \
--localstatedir=/var \
--mandir=/usr/share/man \
--sbindir=/usr/sbin \
--sysconfdir=/etc \
$(DISABLE_NLS) \
$(DISABLE_LARGEFILE) \
--enable-echo \
--enable-const \
--enable-overwrite \
--disable-rpath \
--without-ada \
--without-cxx \
--without-cxx-binding \
--without-debug \
--without-profile \
--with-progs \
--with-normal \
--without-shared \
--with-terminfo-dirs=/usr/share/terminfo \
--with-default-terminfo-dir=/usr/share/terminfo \
);
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
libs install.progs
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \ (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
$(TARGET_CONFIGURE_OPTS) \ $(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \ CFLAGS="$(TARGET_CFLAGS)" \
@ -52,35 +93,30 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
--sysconfdir=/etc \ --sysconfdir=/etc \
$(DISABLE_NLS) \ $(DISABLE_NLS) \
$(DISABLE_LARGEFILE) \ $(DISABLE_LARGEFILE) \
--with-terminfo-dirs=/usr/share/terminfo \
--with-default-terminfo-dir=/usr/share/terminfo \
--without-ada \
--without-cxx \
--without-cxx-binding \
--without-progs \
--without-profile \
--without-debug \
--disable-rpath \
--enable-echo \ --enable-echo \
--enable-const \ --enable-const \
--enable-overwrite \ --enable-overwrite \
--with-shared \ --disable-rpath \
--without-ada \
--without-cxx \
--without-cxx-binding \
--without-debug \
--without-profile \
--without-progs \
--with-normal \ --with-normal \
--with-shared \
--with-terminfo-dirs=/usr/share/terminfo \
--with-default-terminfo-dir=/usr/share/terminfo \
); );
touch $@
$(PKG_BUILD_DIR)/.built:
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \ $(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \ $(TARGET_CONFIGURE_OPTS) \
BUILD_CC="$(TARGET_CC)" \ BUILD_CC="$(TARGET_CC)" \
HOSTCC="$(HOSTCC)" \ HOSTCC="$(HOSTCC)" \
HOSTCCFLAGS="\$$(CPPFLAGS)" \ HOSTCCFLAGS="\$$(CPPFLAGS)" \
DESTDIR="$(PKG_INSTALL_DIR)" \ DESTDIR="$(PKG_INSTALL_DIR)" \
all install libs install.libs install.data
touch $@ touch $@
$(IPKG_LIBNCURSES): $(IPKG_LIBNCURSES):
install -d -m0755 $(IDIR_LIBNCURSES)/usr/lib install -d -m0755 $(IDIR_LIBNCURSES)/usr/lib
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/lib{ncurses,panel}*.so.* $(IDIR_LIBNCURSES)/usr/lib/ cp -fpR $(PKG_INSTALL_DIR)/usr/lib/lib{ncurses,panel}*.so.* $(IDIR_LIBNCURSES)/usr/lib/

View File

@ -1,6 +1,12 @@
config BR_PACKAGE_OSIRIS
bool
default n
depends BR2_PACKAGE_OSIRISD
config BR2_PACKAGE_OSIRISD config BR2_PACKAGE_OSIRISD
tristate "osirisd - Host integrity monitoring system (scanning agent)" tristate "osirisd - Host integrity monitoring system (scanning agent)"
default m if CONFIG_DEVEL default m if CONFIG_DEVEL
select BR2_PACKAGE_OSIRIS
select BR2_PACKAGE_LIBOPENSSL select BR2_PACKAGE_LIBOPENSSL
help help
An host integrity monitoring system (scanning agent) An host integrity monitoring system (scanning agent)
@ -10,6 +16,3 @@ config BR2_PACKAGE_OSIRISD
Depends: openssl Depends: openssl
config BR_PACKAGE_OSIRIS
tristate
default BR2_PACKAGE_OSIRISD

View File

@ -6,3 +6,4 @@ Architecture: [TBDL]
Maintainer: Nico <nthill@free.fr> Maintainer: Nico <nthill@free.fr>
Source: http://nthill.free.fr/openwrt/sources/postgresql/ Source: http://nthill.free.fr/openwrt/sources/postgresql/
Description: Command Line Interface (CLI) to PostgreSQL databases Description: Command Line Interface (CLI) to PostgreSQL databases
Depends: libpq

View File

@ -2,60 +2,62 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME := vtun PKG_NAME:=vtun
PKG_VERSION := 2.6 PKG_VERSION:=2.6
PKG_RELEASE := 1 PKG_RELEASE:=1
PKG_MD5SUM := 309534fd03c5d13a19c43916f61f4bbf PKG_MD5SUM:=309534fd03c5d13a19c43916f61f4bbf
PKG_SOURCE_URL := @SF/vtun PKG_SOURCE_URL:=@SF/vtun
PKG_SOURCE := $(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME) PKG_CAT:=zcat
PKG_CAT := zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
include $(TOPDIR)/package/rules.mk include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,VTUN,vtun,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH))) $(eval $(call PKG_template,VTUN,vtun,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR) ; \ (cd $(PKG_BUILD_DIR) ; rm -rf config.{cache,status} ; \
$(TARGET_CONFIGURE_OPTS) \ $(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS) \ CFLAGS="$(TARGET_CFLAGS)" \
-I$(STAGING_DIR)/usr/include" \ CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \ LIBS="-L$(STAGING_DIR)/usr/lib" \
./configure \ BLOWFISH_HDR_DIR="$(STAGING_DIR)/usr/include/openssl" \
--target=$(GNU_TARGET_NAME) \ LZO_HDR_DIR="$(STAGING_DIR)/usr/include" \
--host=$(GNU_TARGET_NAME) \ SSL_HDR_DIR="$(STAGING_DIR)/usr/include/openssl" \
--build=$(GNU_HOST_NAME) \ ./configure \
--prefix=/usr \ --target=$(GNU_TARGET_NAME) \
--exec-prefix=/usr \ --host=$(GNU_TARGET_NAME) \
--bindir=/usr/bin \ --build=$(GNU_HOST_NAME) \
--sbindir=/usr/sbin \ --program-prefix="" \
--libexecdir=/usr/lib \ --program-suffix="" \
--datadir=/usr/share \ --prefix=/usr \
--infodir=/usr/share/info \ --exec-prefix=/usr \
--mandir=/usr/share/man \ --bindir=/usr/bin \
--localstatedir=/var \ --datadir=/usr/share \
--sysconfdir=/etc \ --includedir=/usr/include \
--with-kernel=$(LINUX_DIR) \ --infodir=/usr/share/info \
--with-zlib=$(STAGING_DIR)/usr/ \ --libdir=/usr/lib \
--with-lzo-headers=$(STAGING_DIR)/usr/include \ --libexecdir=/usr/lib \
--with-lzo-libs=$(STAGING_DIR)/usr/lib \ --localstatedir=/var \
$(DISABLE_NLS) ) --mandir=/usr/share/man \
touch $(PKG_BUILD_DIR)/.configured --sbindir=/usr/sbin \
--sysconfdir=/etc \
$(DISABLE_LARGEFILE) \
$(DISABLE_NLS) \
)
touch $@
$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR) \ $(MAKE) -C $(PKG_BUILD_DIR) \
CC=$(TARGET_CC) \ vtund
CFLAGS="$(TARGET_CFLAGS) \
-I$(STAGING_DIR)/usr/include" \
LDFLAGS="-L$(STAGING_DIR)/usr/lib -lssl -lz -llzo -lcrypto" \
vtund
touch $@ touch $@
$(IPKG_VTUN): $(IPKG_VTUN):
mkdir -p $(IDIR_VTUN)/usr/sbin install -m0755 -d $(IDIR_VTUN)/etc
cp $(PKG_BUILD_DIR)/vtund $(IDIR_VTUN)/usr/sbin/ install -m0600 $(PKG_BUILD_DIR)/vtund.conf $(IDIR_VTUN)/etc/
$(STRIP) $(IDIR_VTUN)/usr/sbin/* install -m0755 -d $(IDIR_VTUN)/usr/sbin
mkdir -p $(IDIR_VTUN)/etc install -m0755 $(PKG_BUILD_DIR)/vtund $(IDIR_VTUN)/usr/sbin/
cp $(PKG_BUILD_DIR)/vtund.conf $(IDIR_VTUN)/etc $(RSTRIP) $(IDIR_VTUN)
$(IPKG_BUILD) $(IDIR_VTUN) $(PACKAGE_DIR) $(IPKG_BUILD) $(IDIR_VTUN) $(PACKAGE_DIR)

View File

@ -5,4 +5,4 @@ Architecture: mipsel
Maintainer: marcel@slowthinkers.net Maintainer: marcel@slowthinkers.net
Source: buildroot internal Source: buildroot internal
Description: A VPN tunnel daemon Description: A VPN tunnel daemon
Depends: openssl, liblzo, zlib, kmod-tun Depends: libopenssl, liblzo, zlib, kmod-tun

View File

@ -4,3 +4,4 @@ Section: net
Maintainer: Nico <nthill@free.fr> Maintainer: Nico <nthill@free.fr>
Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/wpa_supplicant Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/wpa_supplicant
Description: WPA Supplicant with support for WPA and WPA2 Description: WPA Supplicant with support for WPA and WPA2
Depends: libopenssl

View File

@ -0,0 +1,26 @@
Name: CAN-2005-2096 (under review)
Description:
Buffer overflow in zlib 1.2 and later versions allows remote attackers
to cause a denial of service (crash) via a crafted compressed stream, as
demonstrated using a crafted PNG file.
References:
* DEBIAN:DSA-740
http://www.debian.org/security/2005/dsa-740
* REDHAT:RHSA-2005:569
http://www.redhat.com/support/errata/RHSA-2005-569.html
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2096
diff -ruN zlib-1.2.2-old/inftrees.c zlib-1.2.2-new/inftrees.c
--- zlib-1.2.2-old/inftrees.c 2004-09-15 16:30:06.000000000 +0200
+++ zlib-1.2.2-new/inftrees.c 2005-07-08 21:18:58.000000000 +0200
@@ -134,7 +134,7 @@
left -= count[len];
if (left < 0) return -1; /* over-subscribed */
}
- if (left > 0 && (type == CODES || (codes - count[0] != 1)))
+ if (left > 0 && (type == CODES || max != 1))
return -1; /* incomplete set */
/* generate offsets into symbol table for each length for sorting */

View File

@ -115,6 +115,9 @@ $(eval $(call KMOD_template,IDE,ide,\
$(MODULES_DIR)/kernel/drivers/ide/*.o \ $(MODULES_DIR)/kernel/drivers/ide/*.o \
$(MODULES_DIR)/kernel/drivers/ide/*/*.o \ $(MODULES_DIR)/kernel/drivers/ide/*/*.o \
,CONFIG_IDE)) ,CONFIG_IDE))
$(eval $(call KMOD_template,LOOP,loop,\
$(MODULES_DIR)/kernel/drivers/block/loop.o \
,CONFIG_BLK_DEV_LOOP))
$(eval $(call KMOD_template,EXT2,ext2,\ $(eval $(call KMOD_template,EXT2,ext2,\
$(MODULES_DIR)/kernel/fs/ext2/*.o \ $(MODULES_DIR)/kernel/fs/ext2/*.o \
,CONFIG_EXT2_FS)) ,CONFIG_EXT2_FS))