kernel: use -fno-caller-saves

SVN-Revision: 26301
This commit is contained in:
Felix Fietkau 2011-03-26 01:07:16 +00:00
parent 335877a2b3
commit b2b0770576
2 changed files with 13 additions and 7 deletions

View File

@ -1,15 +1,18 @@
--- a/Makefile
+++ b/Makefile
@@ -540,7 +540,7 @@ all: vmlinux
@@ -538,9 +538,9 @@
all: vmlinux
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
KBUILD_CFLAGS += -Os
-KBUILD_CFLAGS += -Os
+KBUILD_CFLAGS += -Os -fno-caller-saves
else
-KBUILD_CFLAGS += -O2
+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
endif
include $(srctree)/arch/$(SRCARCH)/Makefile
@@ -595,6 +595,9 @@ endif
@@ -595,6 +595,9 @@
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)

View File

@ -1,11 +1,14 @@
--- a/Makefile
+++ b/Makefile
@@ -541,7 +541,7 @@ all: vmlinux
@@ -539,9 +539,9 @@ endif # $(dot-config)
all: vmlinux
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
KBUILD_CFLAGS += -Os
-KBUILD_CFLAGS += -Os
+KBUILD_CFLAGS += -Os -fno-caller-saves
else
-KBUILD_CFLAGS += -O2
+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
endif
include $(srctree)/arch/$(SRCARCH)/Makefile