sync with whiterussian

SVN-Revision: 1923
This commit is contained in:
Waldemar Brodkorb 2005-09-14 15:30:53 +00:00
parent 8ceba94522
commit bc3846f81c
4 changed files with 38 additions and 4 deletions

View File

@ -0,0 +1,15 @@
diff -Nur busybox-1.00.orig/networking/udhcp/options.c busybox-1.00/networking/udhcp/options.c
--- busybox-1.00.orig/networking/udhcp/options.c 2004-03-15 09:29:01.000000000 +0100
+++ busybox-1.00/networking/udhcp/options.c 2005-09-14 13:27:23.792609800 +0200
@@ -39,8 +39,11 @@
{"dhcptype", OPTION_U8, 0x35},
{"serverid", OPTION_IP, 0x36},
{"message", OPTION_STRING, 0x38},
+ {"vendorclass", OPTION_STRING, 0x3C},
+ {"clientid", OPTION_STRING, 0x3D},
{"tftp", OPTION_STRING, 0x42},
{"bootfile", OPTION_STRING, 0x43},
+ {"userclass", OPTION_STRING, 0x4D},
{"", 0x00, 0x00}
};

View File

@ -1,7 +1,12 @@
config BR2_PACKAGE_MTD
tristate "mtd - flash utility (always needed)"
tristate "mtd - update utility for trx firmware images"
default y
help
flash utility for firmware images update.
OpenWrt will not work correctly without it.
update utility for trx firmware images.
config BR2_PACKAGE_MTD_STATIC
tristate "mtd - update utility for trx firmware images (statically linked)"
default n
help
update utility for trx firmware images (statically linked). To update
from other firmware or older OpenWrt releases.

View File

@ -3,13 +3,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME := mtd
PKG_RELEASE := 1
PKG_RELEASE := 2
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,MTD,$(PKG_NAME),$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,MTD_STATIC,mtd-static,$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.prepared:
mkdir -p $@
@ -17,6 +18,7 @@ $(PKG_BUILD_DIR)/.prepared:
$(PKG_BUILD_DIR)/.built:
$(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
$(TARGET_CC) -static $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd-static mtd.c
touch $@
$(IPKG_MTD):
@ -24,3 +26,9 @@ $(IPKG_MTD):
install -m0755 $(PKG_BUILD_DIR)/mtd $(IDIR_MTD)/sbin
$(RSTRIP) $(IDIR_MTD)/sbin/*
$(IPKG_BUILD) $(IDIR_MTD) $(PACKAGE_DIR)
$(IPKG_MTD_STATIC):
install -d -m0755 $(IDIR_MTD_STATIC)/sbin
install -m0755 $(PKG_BUILD_DIR)/mtd-static $(IDIR_MTD_STATIC)/sbin
$(RSTRIP) $(IDIR_MTD_STATIC)/sbin/*
$(IPKG_BUILD) $(IDIR_MTD_STATIC) $(PACKAGE_DIR)

View File

@ -0,0 +1,6 @@
Package: mtd-static
Priority: optional
Section: sys
Maintainer: OpenWrt Developer <openwrt-devel@openwrt.org>
Source: buildroot internal
Description: Tool for modifying the flash chip (statically linked)