Update ipset to version 6.20.1

Signed-off-by: Nikolay Martynov <mar.kolya@gmail.com>

SVN-Revision: 38778
This commit is contained in:
Jo-Philipp Wich 2013-11-12 11:00:49 +00:00
parent f1fddbc36b
commit c9bc0e12a9
2 changed files with 2 additions and 18 deletions

View File

@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ipset
PKG_VERSION:=6.16.1
PKG_VERSION:=6.20.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://ipset.netfilter.org
PKG_MD5SUM:=9fd70c825f052db7dc9d5ba0562b7083
PKG_MD5SUM:=8af741492752fbf24d3a28a9d1473d40
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>

View File

@ -1,16 +0,0 @@
--- a/kernel/net/netfilter/ipset/ip_set_core.c
+++ b/kernel/net/netfilter/ipset/ip_set_core.c
@@ -27,6 +27,13 @@
#include <linux/netfilter/nfnetlink.h>
#include <linux/netfilter/ipset/ip_set.h>
+#ifndef IPSET_IN_KERNEL_TREE
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 9, 0)
+#define nfnl_unlock() nfnl_unlock(NFNL_SUBSYS_IPSET)
+#define nfnl_lock() nfnl_lock(NFNL_SUBSYS_IPSET)
+#endif
+#endif
+
static LIST_HEAD(ip_set_type_list); /* all registered set types */
static DEFINE_MUTEX(ip_set_type_mutex); /* protects ip_set_type_list */
static DEFINE_RWLOCK(ip_set_ref_lock); /* protects the set refs */