kernel: remove wrong chunks from the 2.6.37 and 2.6.38 version of the mips oprofile fix

SVN-Revision: 26297
This commit is contained in:
Felix Fietkau 2011-03-25 22:18:17 +00:00
parent a119ee0013
commit def45b136c
2 changed files with 0 additions and 24 deletions

View File

@ -1,15 +1,3 @@
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
@@ -48,6 +48,9 @@ ifneq ($(SUBARCH),$(ARCH))
endif
endif
+ifndef CONFIG_PROFILING
+ cflags-y := -ffunction-sections
+endif
ifdef CONFIG_FUNCTION_GRAPH_TRACER
ifndef KBUILD_MCOUNT_RA_ADDRESS
ifeq ($(call cc-option-yn,-mmcount-ra-address), y)
--- a/arch/mips/oprofile/op_model_mipsxx.c
+++ b/arch/mips/oprofile/op_model_mipsxx.c
@@ -298,6 +298,11 @@ static void reset_counters(void *arg)

View File

@ -1,15 +1,3 @@
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
@@ -48,6 +48,9 @@ ifneq ($(SUBARCH),$(ARCH))
endif
endif
+ifndef CONFIG_PROFILING
+ cflags-y := -ffunction-sections
+endif
ifdef CONFIG_FUNCTION_GRAPH_TRACER
ifndef KBUILD_MCOUNT_RA_ADDRESS
ifeq ($(call cc-option-yn,-mmcount-ra-address), y)
--- a/arch/mips/oprofile/op_model_mipsxx.c
+++ b/arch/mips/oprofile/op_model_mipsxx.c
@@ -298,6 +298,11 @@ static void reset_counters(void *arg)