kernel: update to 2.6.32.10

SVN-Revision: 20444
This commit is contained in:
Gabor Juhos 2010-03-26 10:45:25 +00:00
parent 797967480c
commit e66a368bd1
46 changed files with 107 additions and 126 deletions

View File

@ -17,9 +17,6 @@ endif
ifeq ($(LINUX_VERSION),2.6.31.12)
LINUX_KERNEL_MD5SUM:=517be354b81b780e2f4b2ad614d030de
endif
ifeq ($(LINUX_VERSION),2.6.32.9)
LINUX_KERNEL_MD5SUM:=0771a9c70503c92f40d815ef76eb62fe
endif
ifeq ($(LINUX_VERSION),2.6.32.10)
LINUX_KERNEL_MD5SUM:=5d996507ad482a3a8c8e6b2d48e7994b
endif

View File

@ -11,7 +11,7 @@ BOARD:=ar7
BOARDNAME:=TI AR7
FEATURES:=squashfs jffs2 atm
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk

View File

@ -1,6 +1,6 @@
--- a/arch/mips/kernel/traps.c
+++ b/arch/mips/kernel/traps.c
@@ -1256,9 +1256,22 @@ void *set_except_vector(int n, void *add
@@ -1255,9 +1255,22 @@ void *set_except_vector(int n, void *add
exception_handlers[n] = handler;
if (n == 0 && cpu_has_divec) {
@ -28,7 +28,7 @@
}
--- a/arch/mips/include/asm/page.h
+++ b/arch/mips/include/asm/page.h
@@ -185,8 +185,10 @@ typedef struct { unsigned long pgprot; }
@@ -200,8 +200,10 @@ typedef struct { unsigned long pgprot; }
#define VM_DATA_DEFAULT_FLAGS (VM_READ | VM_WRITE | VM_EXEC | \
VM_MAYREAD | VM_MAYWRITE | VM_MAYEXEC)
@ -40,4 +40,4 @@
+ PHYS_OFFSET)
#include <asm-generic/memory_model.h>
#include <asm-generic/page.h>
#include <asm-generic/getorder.h>

View File

@ -1,6 +1,6 @@
--- a/drivers/serial/8250.c
+++ b/drivers/serial/8250.c
@@ -296,6 +296,13 @@ static const struct serial8250_config ua
@@ -299,6 +299,13 @@ static const struct serial8250_config ua
.fcr = UART_FCR_ENABLE_FIFO | UART_FCR_R_TRIG_00,
.flags = UART_CAP_FIFO | UART_CAP_AFE,
},
@ -14,7 +14,7 @@
};
#if defined (CONFIG_SERIAL_8250_AU1X00)
@@ -2712,7 +2719,11 @@ static void serial8250_console_putchar(s
@@ -2713,7 +2720,11 @@ static void serial8250_console_putchar(s
{
struct uart_8250_port *up = (struct uart_8250_port *)port;

View File

@ -1,8 +1,6 @@
Index: linux-2.6.32.9/arch/mips/ar7/platform.c
===================================================================
--- linux-2.6.32.9.orig/arch/mips/ar7/platform.c 2010-03-07 13:09:00.000000000 +0100
+++ linux-2.6.32.9/arch/mips/ar7/platform.c 2010-03-07 13:09:00.000000000 +0100
@@ -716,23 +716,35 @@
--- a/arch/mips/ar7/platform.c
+++ b/arch/mips/ar7/platform.c
@@ -716,23 +716,35 @@ static int __init ar7_register_devices(v
}
if (ar7_has_high_cpmac()) {
@ -45,11 +43,9 @@ Index: linux-2.6.32.9/arch/mips/ar7/platform.c
if (res)
return res;
Index: linux-2.6.32.9/drivers/net/cpmac.c
===================================================================
--- linux-2.6.32.9.orig/drivers/net/cpmac.c 2010-02-23 16:38:51.000000000 +0100
+++ linux-2.6.32.9/drivers/net/cpmac.c 2010-03-07 13:24:56.000000000 +0100
@@ -1153,6 +1153,8 @@
--- a/drivers/net/cpmac.c
+++ b/drivers/net/cpmac.c
@@ -1153,6 +1153,8 @@ static int __devinit cpmac_probe(struct
goto fail;
}
@ -58,7 +54,7 @@ Index: linux-2.6.32.9/drivers/net/cpmac.c
dev->irq = platform_get_irq_byname(pdev, "irq");
dev->netdev_ops = &cpmac_netdev_ops;
@@ -1228,7 +1230,7 @@
@@ -1228,7 +1230,7 @@ int __devinit cpmac_init(void)
cpmac_mii->reset = cpmac_mdio_reset;
cpmac_mii->irq = mii_irqs;
@ -67,7 +63,7 @@ Index: linux-2.6.32.9/drivers/net/cpmac.c
if (!cpmac_mii->priv) {
printk(KERN_ERR "Can't ioremap mdio registers\n");
@@ -1239,10 +1241,17 @@
@@ -1239,10 +1241,17 @@ int __devinit cpmac_init(void)
#warning FIXME: unhardcode gpio&reset bits
ar7_gpio_disable(26);
ar7_gpio_disable(27);
@ -87,7 +83,7 @@ Index: linux-2.6.32.9/drivers/net/cpmac.c
cpmac_mii->reset(cpmac_mii);
for (i = 0; i < 300; i++)
@@ -1257,7 +1266,8 @@
@@ -1257,7 +1266,8 @@ int __devinit cpmac_init(void)
mask = 0;
}
@ -97,11 +93,9 @@ Index: linux-2.6.32.9/drivers/net/cpmac.c
snprintf(cpmac_mii->id, MII_BUS_ID_SIZE, "1");
res = mdiobus_register(cpmac_mii);
Index: a/arch/mips/include/asm/mach-ar7/ar7.h
===================================================================
--- a/arch/mips/include/asm/mach-ar7/ar7.h (revision 19112)
+++ b/arch/mips/include/asm/mach-ar7/ar7.h (working copy)
@@ -44,8 +44,10 @@
--- a/arch/mips/include/asm/mach-ar7/ar7.h
+++ b/arch/mips/include/asm/mach-ar7/ar7.h
@@ -50,8 +50,10 @@
#define UR8_REGS_WDT (AR7_REGS_BASE + 0x0b00)
#define UR8_REGS_UART1 (AR7_REGS_BASE + 0x0f00)

View File

@ -1,8 +1,6 @@
Index: linux-2.6.32.9/drivers/net/cpmac.c
===================================================================
--- linux-2.6.32.9.orig/drivers/net/cpmac.c 2010-03-06 23:12:46.000000000 +0100
+++ linux-2.6.32.9/drivers/net/cpmac.c 2010-03-06 23:13:14.000000000 +0100
@@ -1132,8 +1132,9 @@
--- a/drivers/net/cpmac.c
+++ b/drivers/net/cpmac.c
@@ -1132,8 +1132,9 @@ static int __devinit cpmac_probe(struct
}
if (phy_id == PHY_MAX_ADDR) {

View File

@ -1,8 +1,8 @@
--- a/drivers/net/cpmac.c 2010-02-11 23:52:19.000000000 +0000
+++ b/drivers/net/cpmac.c 2010-02-20 20:32:58.000000000 +0000
@@ -57,7 +57,7 @@
--- a/drivers/net/cpmac.c
+++ b/drivers/net/cpmac.c
@@ -56,7 +56,7 @@ MODULE_PARM_DESC(dumb_switch, "Assume sw
#define CPMAC_VERSION "0.5.0"
#define CPMAC_VERSION "0.5.1"
/* frame size + 802.1q tag */
-#define CPMAC_SKB_SIZE (ETH_FRAME_LEN + 4)
+#define CPMAC_SKB_SIZE (ETH_FRAME_LEN + ETH_FCS_LEN + 4)

View File

@ -12,7 +12,7 @@ BOARDNAME:=Atheros AR71xx/AR7240/AR913x
FEATURES:=squashfs jffs2 tgz
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk

View File

@ -12,7 +12,7 @@ BOARDNAME:=RMI/AMD AU1x00
FEATURES:=jffs2 usb pci
SUBTARGETS=au1500 au1550
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini yamonenv

View File

@ -8,7 +8,7 @@
#include <prom.h>
@@ -49,7 +49,7 @@ void __init prom_init(void)
@@ -49,7 +50,7 @@ void __init prom_init(void)
prom_argv = (char **)fw_arg1;
prom_envp = (char **)fw_arg2;
@ -17,4 +17,3 @@
memsize_str = prom_getenv("memsize");
if (!memsize_str)

View File

@ -1,6 +1,6 @@
--- a/drivers/net/au1000_eth.c
+++ b/drivers/net/au1000_eth.c
@@ -1036,10 +1036,14 @@ static void au1000_multicast_list(struct
@@ -1035,10 +1035,14 @@ static void au1000_multicast_list(struct
}
}

View File

@ -1,6 +1,6 @@
--- a/drivers/net/au1000_eth.c
+++ b/drivers/net/au1000_eth.c
@@ -166,6 +166,15 @@ struct au1000_private *au_macs[NUM_ETH_I
@@ -167,6 +167,15 @@ struct au1000_private *au_macs[NUM_ETH_I
# undef AU1XXX_PHY1_IRQ
#endif
@ -16,7 +16,7 @@
#if defined(AU1XXX_PHY0_BUSID) && (AU1XXX_PHY0_BUSID > 0)
# error MAC0-associated PHY attached 2nd MACs MII bus not supported yet
#endif
@@ -483,6 +492,12 @@ static int mii_probe (struct net_device
@@ -484,6 +493,12 @@ static int mii_probe (struct net_device
aup->old_duplex = -1;
aup->phy_dev = phydev;

View File

@ -10,7 +10,7 @@ ARCH:=avr32
BOARD:=avr32
BOARDNAME:=Atmel AVR32
FEATURES:=squashfs
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk

View File

@ -11,7 +11,7 @@ BOARD:=brcm47xx
BOARDNAME:=Broadcom BCM947xx/953xx
FEATURES:=squashfs usb pcmcia
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram

View File

@ -1,8 +1,6 @@
Index: linux-2.6.33/drivers/ssb/driver_pcicore.c
===================================================================
--- linux-2.6.33.orig/drivers/ssb/driver_pcicore.c 2010-03-15 14:52:55.000000000 +0100
+++ linux-2.6.33/drivers/ssb/driver_pcicore.c 2010-03-15 15:57:38.000000000 +0100
@@ -246,20 +246,12 @@
--- a/drivers/ssb/driver_pcicore.c
+++ b/drivers/ssb/driver_pcicore.c
@@ -246,20 +246,12 @@ static struct pci_controller ssb_pcicore
.pci_ops = &ssb_pcicore_pciops,
.io_resource = &ssb_pcicore_io_resource,
.mem_resource = &ssb_pcicore_mem_resource,
@ -23,7 +21,7 @@ Index: linux-2.6.33/drivers/ssb/driver_pcicore.c
if (d->bus->ops != &ssb_pcicore_pciops) {
/* This is not a device on the PCI-core bridge. */
return -ENODEV;
@@ -268,27 +260,6 @@
@@ -268,27 +260,6 @@ int ssb_pcicore_plat_dev_init(struct pci
ssb_printk(KERN_INFO "PCI: Fixing up device %s\n",
pci_name(d));

View File

@ -1,8 +1,6 @@
Index: linux-2.6.32.9/drivers/pcmcia/yenta_socket.c
===================================================================
--- linux-2.6.32.9.orig/drivers/pcmcia/yenta_socket.c 2010-03-12 09:43:45.000000000 +0100
+++ linux-2.6.32.9/drivers/pcmcia/yenta_socket.c 2010-03-12 10:05:33.000000000 +0100
@@ -866,6 +866,8 @@
--- a/drivers/pcmcia/yenta_socket.c
+++ b/drivers/pcmcia/yenta_socket.c
@@ -866,6 +866,8 @@ static unsigned int yenta_probe_irq(stru
* Probe for usable interrupts using the force
* register to generate bogus card status events.
*/
@ -11,7 +9,7 @@ Index: linux-2.6.32.9/drivers/pcmcia/yenta_socket.c
cb_writel(socket, CB_SOCKET_EVENT, -1);
cb_writel(socket, CB_SOCKET_MASK, CB_CSTSMASK);
exca_writeb(socket, I365_CSCINT, 0);
@@ -880,6 +882,7 @@
@@ -880,6 +882,7 @@ static unsigned int yenta_probe_irq(stru
}
cb_writel(socket, CB_SOCKET_MASK, 0);
exca_writeb(socket, I365_CSCINT, 0);
@ -19,7 +17,7 @@ Index: linux-2.6.32.9/drivers/pcmcia/yenta_socket.c
mask = probe_irq_mask(val) & 0xffff;
@@ -960,6 +963,10 @@
@@ -960,6 +963,10 @@ static void yenta_get_socket_capabilitie
else
socket->socket.irq_mask = 0;
@ -30,7 +28,7 @@ Index: linux-2.6.32.9/drivers/pcmcia/yenta_socket.c
dev_printk(KERN_INFO, &socket->dev->dev,
"ISA IRQ mask 0x%04x, PCI irq %d\n",
socket->socket.irq_mask, socket->cb_irq);
@@ -1198,6 +1205,15 @@
@@ -1198,6 +1205,15 @@ static int __devinit yenta_probe (struct
dev_printk(KERN_INFO, &dev->dev,
"Socket status: %08x\n", cb_readl(socket, CB_SOCKET_STATE));

View File

@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM63xx
FEATURES:=squashfs jffs2 usb atm pci pcmcia
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk

View File

@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
@@ -467,6 +467,49 @@
@@ -467,6 +467,49 @@ static struct board_info __initdata boar
.has_ohci0 = 1,
};
@ -50,7 +50,7 @@
#endif
/*
@@ -692,6 +735,7 @@
@@ -692,6 +735,7 @@ static const struct board_info __initdat
&board_DV201AMR,
&board_96348gw_a,
&board_rta1025w_16,

View File

@ -12,7 +12,7 @@ BOARDNAME:=Cobalt Microservers
FEATURES:=tgz pci ext2
CFLAGS:=-O2 -pipe -mtune=r5000 -funit-at-a-time
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk

View File

@ -1,7 +1,6 @@
diff -urN linux-2.6.32.7/arch/mips/Makefile linux-2.6.32.7.new/arch/mips/Makefile
--- linux-2.6.32.7/arch/mips/Makefile 2010-02-01 18:06:35.000000000 +0100
+++ linux-2.6.32.7.new/arch/mips/Makefile 2010-01-29 00:06:20.000000000 +0100
@@ -83,7 +83,7 @@
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
@@ -85,7 +85,7 @@ all-$(CONFIG_BOOT_ELF64) := $(vmlinux-64
cflags-y += -G 0 -mno-abicalls -fno-pic -pipe
cflags-y += -msoft-float
LDFLAGS_vmlinux += -G 0 -static -n -nostdlib
@ -10,10 +9,9 @@ diff -urN linux-2.6.32.7/arch/mips/Makefile linux-2.6.32.7.new/arch/mips/Makefil
cflags-y += -ffreestanding
diff -urN linux-2.6.32.7/arch/mips/include/asm/module.h linux-2.6.32.7.new/arch/mips/include/asm/module.h
--- linux-2.6.32.7/arch/mips/include/asm/module.h 2010-02-01 18:06:35.000000000 +0100
+++ linux-2.6.32.7.new/arch/mips/include/asm/module.h 2010-01-29 00:06:20.000000000 +0100
@@ -9,11 +9,6 @@
--- a/arch/mips/include/asm/module.h
+++ b/arch/mips/include/asm/module.h
@@ -9,11 +9,6 @@ struct mod_arch_specific {
struct list_head dbe_list;
const struct exception_table_entry *dbe_start;
const struct exception_table_entry *dbe_end;
@ -25,10 +23,9 @@ diff -urN linux-2.6.32.7/arch/mips/include/asm/module.h linux-2.6.32.7.new/arch/
};
typedef uint8_t Elf64_Byte; /* Type for a 8-bit quantity. */
diff -urN linux-2.6.32.7/arch/mips/kernel/module.c linux-2.6.32.7.new/arch/mips/kernel/module.c
--- linux-2.6.32.7/arch/mips/kernel/module.c 2010-02-01 18:06:35.000000000 +0100
+++ linux-2.6.32.7.new/arch/mips/kernel/module.c 2010-01-29 00:06:20.000000000 +0100
@@ -43,117 +43,6 @@
--- a/arch/mips/kernel/module.c
+++ b/arch/mips/kernel/module.c
@@ -43,117 +43,6 @@ static struct mips_hi16 *mips_hi16_list;
static LIST_HEAD(dbe_list);
static DEFINE_SPINLOCK(dbe_lock);
@ -146,7 +143,7 @@ diff -urN linux-2.6.32.7/arch/mips/kernel/module.c linux-2.6.32.7.new/arch/mips/
void *module_alloc(unsigned long size)
{
#ifdef MODULE_START
@@ -169,99 +58,21 @@
@@ -169,99 +58,21 @@ void *module_alloc(unsigned long size)
return __vmalloc_area(area, GFP_KERNEL, PAGE_KERNEL);
#else
@ -248,7 +245,7 @@ diff -urN linux-2.6.32.7/arch/mips/kernel/module.c linux-2.6.32.7.new/arch/mips/
return 0;
}
@@ -284,36 +95,28 @@
@@ -284,36 +95,28 @@ static int apply_r_mips_32_rela(struct m
return 0;
}
@ -301,7 +298,7 @@ diff -urN linux-2.6.32.7/arch/mips/kernel/module.c linux-2.6.32.7.new/arch/mips/
{
if (v % 4) {
pr_err("module %s: dangerous R_MIPS_26 RELArelocation\n",
@@ -322,31 +125,17 @@
@@ -322,31 +125,17 @@ static int set_r_mips_26(struct module *
}
if ((v & 0xf0000000) != (((unsigned long)location + 4) & 0xf0000000)) {
@ -336,7 +333,7 @@ diff -urN linux-2.6.32.7/arch/mips/kernel/module.c linux-2.6.32.7.new/arch/mips/
static int apply_r_mips_hi16_rel(struct module *me, u32 *location, Elf_Addr v)
{
struct mips_hi16 *n;
@@ -611,32 +400,11 @@
@@ -611,32 +400,11 @@ int module_finalize(const Elf_Ehdr *hdr,
list_add(&me->arch.dbe_list, &dbe_list);
spin_unlock_irq(&dbe_lock);
}

View File

@ -10,7 +10,7 @@ ARCH:=cris
BOARD:=etrax
BOARDNAME:=Foxboard (ETRAX 100LX)
FEATURES:=squashfs jffs2
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
DEVICE_TYPE=
include $(INCLUDE_DIR)/target.mk

View File

@ -49,5 +49,5 @@
-OBJCOPYFLAGS := -O binary -R .note -R .comment -S
+OBJCOPYFLAGS := -O binary -R .bss -R .note -R .note.gnu.build-id -R .comment -S
CPPFLAGS_vmlinux.lds = -DDRAM_VIRTUAL_BASE=0x$(CONFIG_ETRAX_DRAM_VIRTUAL_BASE)
KBUILD_AFLAGS += -mlinux -march=$(arch-y) $(inc)
KBUILD_CFLAGS += -mlinux -march=$(arch-y) -pipe $(inc)

View File

@ -1,6 +1,6 @@
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
@@ -385,7 +385,7 @@ struct mtd_info *cfi_cmdset_0002(struct
@@ -374,7 +374,7 @@ struct mtd_info *cfi_cmdset_0002(struct
cfi_fixup_major_minor(cfi, extp);

View File

@ -1,7 +1,7 @@
--- a/drivers/usb/host/Makefile
+++ b/drivers/usb/host/Makefile
@@ -25,6 +25,7 @@ obj-$(CONFIG_USB_UHCI_HCD) += uhci-hcd.o
obj-$(CONFIG_USB_FHCI_HCD) += fhci.o
@@ -28,6 +28,7 @@ obj-$(CONFIG_USB_FHCI_HCD) += fhci.o
obj-$(CONFIG_USB_XHCI_HCD) += xhci.o
obj-$(CONFIG_USB_SL811_HCD) += sl811-hcd.o
obj-$(CONFIG_USB_SL811_CS) += sl811_cs.o
+obj-$(CONFIG_ETRAX_USB_HOST) += hc-crisv10.o
@ -10,7 +10,7 @@
obj-$(CONFIG_USB_ISP1760_HCD) += isp1760.o
--- a/drivers/usb/Makefile
+++ b/drivers/usb/Makefile
@@ -19,6 +19,7 @@ obj-$(CONFIG_USB_U132_HCD) += host/
@@ -21,6 +21,7 @@ obj-$(CONFIG_USB_U132_HCD) += host/
obj-$(CONFIG_USB_R8A66597_HCD) += host/
obj-$(CONFIG_USB_HWA_HCD) += host/
obj-$(CONFIG_USB_ISP1760_HCD) += host/

View File

@ -1,6 +1,6 @@
--- a/drivers/serial/crisv10.c
+++ b/drivers/serial/crisv10.c
@@ -31,6 +31,7 @@ static char *serial_version = "$Revision
@@ -32,6 +32,7 @@ static char *serial_version = "$Revision
#include <linux/module.h>
#include <linux/uaccess.h>
#include <linux/io.h>
@ -8,7 +8,7 @@
#include <asm/irq.h>
#include <asm/dma.h>
@@ -4414,6 +4415,8 @@ static const struct tty_operations rs_op
@@ -4415,6 +4416,8 @@ static const struct tty_operations rs_op
#endif
};
@ -17,7 +17,7 @@
static int __init rs_init(void)
{
int i;
@@ -4547,6 +4550,24 @@ static int __init rs_init(void)
@@ -4548,6 +4551,24 @@ static int __init rs_init(void)
#endif
#endif /* CONFIG_SVINTO_SIM */

View File

@ -12,7 +12,7 @@ BOARDNAME:=Cortina Systems CS351x
FEATURES:=squashfs
CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk

View File

@ -68,7 +68,7 @@
* macro override instead of weak attribute alias, to workaround
--- a/kernel/sched.c
+++ b/kernel/sched.c
@@ -6093,6 +6093,7 @@ int can_nice(const struct task_struct *p
@@ -6105,6 +6105,7 @@ int can_nice(const struct task_struct *p
return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
capable(CAP_SYS_NICE));
}

View File

@ -11,7 +11,7 @@ BOARD:=iop32x
BOARDNAME:=Intel IOP32x
FEATURES:=squashfs
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk

View File

@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
FEATURES:=squashfs
SUBTARGETS=generic harddisk
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk

View File

@ -124,7 +124,7 @@
unsigned int custom_divisor;
--- a/drivers/serial/8250.c
+++ b/drivers/serial/8250.c
@@ -406,6 +406,20 @@ static void mem_serial_out(struct uart_p
@@ -409,6 +409,20 @@ static void mem_serial_out(struct uart_p
writeb(value, p->membase + offset);
}
@ -145,7 +145,7 @@
static void mem32_serial_out(struct uart_port *p, int offset, int value)
{
offset = map_8250_out_reg(p, offset) << p->regshift;
@@ -499,6 +513,11 @@ static void set_io_from_upio(struct uart
@@ -502,6 +516,11 @@ static void set_io_from_upio(struct uart
p->serial_out = mem32_serial_out;
break;
@ -157,7 +157,7 @@
#ifdef CONFIG_SERIAL_8250_AU1X00
case UPIO_AU:
p->serial_in = au_serial_in;
@@ -531,6 +550,7 @@ serial_out_sync(struct uart_8250_port *u
@@ -534,6 +553,7 @@ serial_out_sync(struct uart_8250_port *u
switch (p->iotype) {
case UPIO_MEM:
case UPIO_MEM32:
@ -165,7 +165,7 @@
#ifdef CONFIG_SERIAL_8250_AU1X00
case UPIO_AU:
#endif
@@ -2449,6 +2469,7 @@ static int serial8250_request_std_resour
@@ -2450,6 +2470,7 @@ static int serial8250_request_std_resour
case UPIO_MEM32:
case UPIO_MEM:
case UPIO_DWAPB:
@ -173,7 +173,7 @@
if (!up->port.mapbase)
break;
@@ -2486,6 +2507,7 @@ static void serial8250_release_std_resou
@@ -2487,6 +2508,7 @@ static void serial8250_release_std_resou
case UPIO_MEM32:
case UPIO_MEM:
case UPIO_DWAPB:
@ -181,7 +181,7 @@
if (!up->port.mapbase)
break;
@@ -2958,6 +2980,7 @@ static int __devinit serial8250_probe(st
@@ -2959,6 +2981,7 @@ static int __devinit serial8250_probe(st
port.serial_in = p->serial_in;
port.serial_out = p->serial_out;
port.dev = &dev->dev;
@ -189,7 +189,7 @@
if (share_irqs)
port.irqflags |= IRQF_SHARED;
ret = serial8250_register_port(&port);
@@ -3108,6 +3131,7 @@ int serial8250_register_port(struct uart
@@ -3109,6 +3132,7 @@ int serial8250_register_port(struct uart
uart->port.iotype = port->iotype;
uart->port.flags = port->flags | UPF_BOOT_AUTOCONF;
uart->port.mapbase = port->mapbase;

View File

@ -12,7 +12,7 @@ BOARDNAME:=MIPS Malta CoreLV board (qemu)
FEATURES:=ramdisk
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
LINUX_VERSION:=2.6.32.8
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk

View File

@ -12,7 +12,7 @@ BOARDNAME:=TI OMAP35xx
FEATURES:=broken
SUBTARGETS=generic
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
KERNELNAME:="uImage"
DEVICE_TYPE=developerboard

View File

@ -13,7 +13,7 @@ FEATURES:=squashfs
SUBTARGETS=generic harddisk
CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk

View File

@ -1,5 +1,5 @@
--- a/arch/arm/mach-orion5x/wrt350n-v2-setup.c 2009-12-08 02:39:46.000000000 +0100
+++ b/arch/arm/mach-orion5x/wrt350n-v2-setup.c 2010-01-13 15:25:17.000000000 +0100
--- a/arch/arm/mach-orion5x/wrt350n-v2-setup.c
+++ b/arch/arm/mach-orion5x/wrt350n-v2-setup.c
@@ -15,6 +15,9 @@
#include <linux/mtd/physmap.h>
#include <linux/mv643xx_eth.h>
@ -91,7 +91,7 @@
static struct orion5x_mpp_mode wrt350n_v2_mpp_modes[] __initdata = {
{ 0, MPP_GPIO }, /* Power LED green (0=on) */
{ 1, MPP_GPIO }, /* Security LED (0=on) */
@@ -140,6 +217,8 @@
@@ -140,6 +217,8 @@ static void __init wrt350n_v2_init(void)
orion5x_setup_dev_boot_win(WRT350N_V2_NOR_BOOT_BASE,
WRT350N_V2_NOR_BOOT_SIZE);
platform_device_register(&wrt350n_v2_nor_flash);

View File

@ -1,6 +1,6 @@
--- a/arch/arm/mach-orion5x/wrt350n-v2-setup.c
+++ b/arch/arm/mach-orion5x/wrt350n-v2-setup.c
@@ -135,11 +135,11 @@ static struct mtd_partition wrt350n_v2_nor_flash_partitions
@@ -135,11 +135,11 @@ static struct mtd_partition wrt350n_v2_n
{
.name = "kernel",
.offset = 0x00000000,
@ -9,13 +9,13 @@
}, {
.name = "rootfs",
- .offset = 0x001a0000,
+ .offset = 0x00100000, // change to kernel mtd size here (2/3)
- .size = 0x005c0000,
+ .offset = 0x00100000, // change to kernel mtd size here (2/3)
+ .size = 0x00650000, // adopt to kernel mtd size here (3/3) = 0x00750000 - <kernel mtd size>
}, {
.name = "lang",
.offset = 0x00760000,
@@ -152,6 +152,14 @@ static struct mtd_partition wrt350n_v2_nor_flash_partitions
@@ -152,6 +152,14 @@ static struct mtd_partition wrt350n_v2_n
.name = "u-boot",
.offset = 0x007c0000,
.size = 0x00040000,

View File

@ -1,6 +1,6 @@
--- a/arch/arm/mach-orion5x/wnr854t-setup.c
+++ b/arch/arm/mach-orion5x/wnr854t-setup.c
@@ -67,6 +67,10 @@ static struct mtd_partition wnr854t_nor_flash_partitions
@@ -67,6 +67,10 @@ static struct mtd_partition wnr854t_nor_
.name = "uboot",
.offset = 0x00760000,
.size = 0x00040000,

View File

@ -12,7 +12,7 @@ BOARDNAME:=AMCC/IBM PPC40x
FEATURES:=squashfs
CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=405
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk

View File

@ -12,7 +12,7 @@ BOARDNAME:=AMCC/IBM PPC44x
FEATURES:=squashfs
CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk

View File

@ -11,7 +11,7 @@ BOARD:=pxa
BOARDNAME:=Marvell/Intel PXA2xx
FEATURES:=squashfs
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk

View File

@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
FEATURES:=squashfs broken
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=kmod-leds-gpio

View File

@ -1,6 +1,6 @@
--- a/drivers/serial/8250.c
+++ b/drivers/serial/8250.c
@@ -298,9 +298,9 @@ static const struct serial8250_config ua
@@ -301,9 +301,9 @@ static const struct serial8250_config ua
},
};
@ -12,7 +12,7 @@
static const u8 au_io_in_map[] = {
[UART_RX] = 0,
[UART_IER] = 2,
@@ -418,7 +418,7 @@ static unsigned int mem32_serial_in(stru
@@ -421,7 +421,7 @@ static unsigned int mem32_serial_in(stru
return readl(p->membase + offset);
}
@ -21,7 +21,7 @@
static unsigned int au_serial_in(struct uart_port *p, int offset)
{
offset = map_8250_in_reg(p, offset) << p->regshift;
@@ -499,7 +499,7 @@ static void set_io_from_upio(struct uart
@@ -502,7 +502,7 @@ static void set_io_from_upio(struct uart
p->serial_out = mem32_serial_out;
break;
@ -30,7 +30,7 @@
case UPIO_AU:
p->serial_in = au_serial_in;
p->serial_out = au_serial_out;
@@ -531,7 +531,7 @@ serial_out_sync(struct uart_8250_port *u
@@ -534,7 +534,7 @@ serial_out_sync(struct uart_8250_port *u
switch (p->iotype) {
case UPIO_MEM:
case UPIO_MEM32:
@ -39,7 +39,7 @@
case UPIO_AU:
#endif
case UPIO_DWAPB:
@@ -569,8 +569,8 @@ static inline void _serial_dl_write(stru
@@ -572,8 +572,8 @@ static inline void _serial_dl_write(stru
serial_outp(up, UART_DLM, value >> 8 & 0xff);
}
@ -50,7 +50,7 @@
static int serial_dl_read(struct uart_8250_port *up)
{
if (up->port.iotype == UPIO_AU)
@@ -777,22 +777,19 @@ static int size_fifo(struct uart_8250_po
@@ -780,22 +780,19 @@ static int size_fifo(struct uart_8250_po
*/
static unsigned int autoconfig_read_divisor_id(struct uart_8250_port *p)
{
@ -79,7 +79,7 @@
serial_outp(p, UART_LCR, old_lcr);
return id;
@@ -1214,7 +1211,7 @@ static void autoconfig(struct uart_8250_
@@ -1217,7 +1214,7 @@ static void autoconfig(struct uart_8250_
}
#endif

View File

@ -11,7 +11,7 @@ BOARD:=rb532
BOARDNAME:=Mikrotik RouterBoard 532
FEATURES:=jffs2 pci tgz
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532

View File

@ -12,7 +12,7 @@ BOARDNAME:=Broadcom/SiByte SB-1
FEATURES:=fpu
CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk

View File

@ -1,6 +1,6 @@
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
@@ -83,7 +83,7 @@ all-$(CONFIG_BOOT_ELF64) := $(vmlinux-64
@@ -85,7 +85,7 @@ all-$(CONFIG_BOOT_ELF64) := $(vmlinux-64
cflags-y += -G 0 -mno-abicalls -fno-pic -pipe
cflags-y += -msoft-float
LDFLAGS_vmlinux += -G 0 -static -n -nostdlib

View File

@ -12,7 +12,7 @@ BOARDNAME:=x86
FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia tgz
SUBTARGETS=generic olpc xen_domu
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
include $(INCLUDE_DIR)/target.mk

View File

@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
FEATURES:=jffs2 tgz ubifs audio
SUBTARGETS:=qi_lb60 n516 n526
LINUX_VERSION:=2.6.32.9
LINUX_VERSION:=2.6.32.10
DEVICE_TYPE=other