madwifi: disable debug by default in the source tree instead of only relying on the override (useful for external builds)

SVN-Revision: 17085
This commit is contained in:
Felix Fietkau 2009-08-01 21:29:15 +00:00
parent 9ce792f444
commit f6852f2023

View File

@ -204,12 +204,14 @@
#include <linux/wireless.h>
--- a/Makefile.inc
+++ b/Makefile.inc
@@ -148,7 +148,8 @@ ATH_RATE= $(TOP)/ath_rate
@@ -147,8 +147,9 @@ ATH_RATE= $(TOP)/ath_rate
#
TOOLS= $(TOP)/tools
WARNINGS = -Werror
-WARNINGS = -Werror
-COPTS+= $(WARNINGS)
+DEBUG = -DAR_DEBUG -DIEEE80211_DEBUG
+WARNINGS = -Wno-unused
+# DEBUG = -DAR_DEBUG -DIEEE80211_DEBUG
+COPTS+= $(WARNINGS) $(DEBUG)
INCS= -include $(TOP)/include/compat.h -I$(TOP)/include