tn3399_openwrt/tools/sstrip/patches/001-disable-elftoc-compilation.patch
Rui Salvaterra 3f567d8452 tools/sstrip: update to latest version
Drop our local sstrip copy and use the current ELFKickers upstream
version.

Patch the original makefile in order to avoid building elftoc, since it
fails with musl's elf.h. This is fine, since we only need sstrip anyway.

Finally, add the possibility to pass additional arguments to sstrip and
pass -z (remove trailing zeros) by default, which matches the behaviour
of the previous version.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
[shorten long commit msg lines]
Signed-off-by: Paul Spooren <mail@aparcar.org>
2020-11-26 12:44:25 -10:00

29 lines
718 B
Diff

From: Rui Salvaterra <rsalvaterra@gmail.com>
Subject: sstrip: don't try to compile elftoc
We only need sstrip itself and elftoc doesn't compile with musl's elf.h, so
disable the elftoc compilation in the makefile.
Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
---
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,7 @@
prefix = /usr/local
-PROGRAMS = elfls objres rebind sstrip elftoc ebfc infect
+PROGRAMS = elfls objres rebind sstrip ebfc infect
all: $(PROGRAMS)
@@ -19,7 +19,6 @@ elfls: bin/elfls doc/elfls.1
objres: bin/objres doc/objres.1
rebind: bin/rebind doc/rebind.1
sstrip: bin/sstrip doc/sstrip.1
-elftoc: bin/elftoc doc/elftoc.1
ebfc: bin/ebfc doc/ebfc.1
infect: bin/infect doc/infect.1