tn3399_openwrt/target/linux/oxnas/patches-3.18/310-oxnas-clocksource.patch
John Crispin 72b58f2eb1 add new target 'oxnas'
This is the oxnas target previously developed at
http://gitorious.org/openwrt-oxnas
Basically, this consolidates the changes and addtionas from
http://github.org/kref/linux-oxnas
into a new OpenWrt hardware target 'oxnas' adding support for
 PLX Technology NAS7820/NAS7821/NAS7825/...
formally known as
 Oxford Semiconductor OXE810SE/OXE815/OX820/...

For now there are 4 supported boards:
Cloud Engines Pogoplug V3 (without PCIe)
 fully supported

Cloud Engines Pogoplug Pro (with PCIe)
 fully supported

MitraStar STG-212
 aka ZyXEL NSA-212,
 aka Medion Akoya P89625 / P89636 / P89626 / P89630,
 aka Medion MD 86407 / MD 86805 / MD 86517 / MD 86587
 fully supported, see http://wiki.openwrt.org/toh/medion/md86587

Shuttle KD-20
 partially supported (S-ATA driver lacks support for 2nd port)

Signed-off-by: Daniel Golle <daniel@makrotopia.org>

SVN-Revision: 43388
2014-11-26 09:00:08 +00:00

30 lines
1.1 KiB
Diff

Index: linux-3.18-rc4/drivers/clocksource/Kconfig
===================================================================
--- linux-3.18-rc4.orig/drivers/clocksource/Kconfig
+++ linux-3.18-rc4/drivers/clocksource/Kconfig
@@ -156,6 +156,12 @@ config VF_PIT_TIMER
help
Support for Period Interrupt Timer on Freescale Vybrid Family SoCs.
+config CLKSRC_RPS_TIMER
+ def_bool y if ARCH_OXNAS
+ select CLKSRC_MMIO
+ help
+ This option enables support for the oxnas rps timers.
+
config SYS_SUPPORTS_SH_CMT
bool
Index: linux-3.18-rc4/drivers/clocksource/Makefile
===================================================================
--- linux-3.18-rc4.orig/drivers/clocksource/Makefile
+++ linux-3.18-rc4/drivers/clocksource/Makefile
@@ -36,6 +36,7 @@ obj-$(CONFIG_CLKSRC_EFM32) += time-efm32
obj-$(CONFIG_CLKSRC_EXYNOS_MCT) += exynos_mct.o
obj-$(CONFIG_CLKSRC_SAMSUNG_PWM) += samsung_pwm_timer.o
obj-$(CONFIG_FSL_FTM_TIMER) += fsl_ftm_timer.o
+obj-$(CONFIG_CLKSRC_RPS_TIMER) += oxnas_rps_timer.o
obj-$(CONFIG_VF_PIT_TIMER) += vf_pit_timer.o
obj-$(CONFIG_CLKSRC_QCOM) += qcom-timer.o
obj-$(CONFIG_MTK_TIMER) += mtk_timer.o