tn3399_openwrt/target/linux/oxnas/patches-4.0/350-oxnas-reset.patch
John Crispin 3256194aff oxnas: add support for kernel 4.0
Signed-off-by: Daniel Golle <daniel@makrotopia.org>

SVN-Revision: 44922
2015-03-21 21:47:03 +00:00

25 lines
820 B
Diff

Index: linux-4.0-rc4/drivers/reset/Kconfig
===================================================================
--- linux-4.0-rc4.orig/drivers/reset/Kconfig
+++ linux-4.0-rc4/drivers/reset/Kconfig
@@ -12,4 +12,9 @@ menuconfig RESET_CONTROLLER
If unsure, say no.
+config RESET_CONTROLLER_OXNAS
+ bool
+ select RESET_CONTROLLER
+
source "drivers/reset/sti/Kconfig"
+
Index: linux-4.0-rc4/drivers/reset/Makefile
===================================================================
--- linux-4.0-rc4.orig/drivers/reset/Makefile
+++ linux-4.0-rc4/drivers/reset/Makefile
@@ -1,4 +1,5 @@
obj-$(CONFIG_RESET_CONTROLLER) += core.o
+obj-$(CONFIG_RESET_CONTROLLER_OXNAS) += reset-ox820.o
obj-$(CONFIG_ARCH_SOCFPGA) += reset-socfpga.o
obj-$(CONFIG_ARCH_BERLIN) += reset-berlin.o
obj-$(CONFIG_ARCH_SUNXI) += reset-sunxi.o