tn3399_openwrt/tools/cmake/patches/100-disable_qt_tests.patch
Hannu Nyman 3c4df661c0 tools/cmake: update to 3.10.1
Update cmake to 3.10.1
Refresh patches

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
2018-01-17 08:52:54 +01:00

35 lines
1.1 KiB
Diff

--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -273,15 +273,6 @@ add_RunCMake_test(no_install_prefix)
add_RunCMake_test(configure_file)
add_RunCMake_test(CTestTimeoutAfterMatch)
-find_package(Qt4 QUIET)
-find_package(Qt5Core QUIET)
-if (QT4_FOUND AND Qt5Core_FOUND AND NOT Qt5Core_VERSION VERSION_LESS 5.1.0)
- add_RunCMake_test(IncompatibleQt)
-endif()
-if (QT4_FOUND)
- add_RunCMake_test(ObsoleteQtMacros -DQT_QMAKE_EXECUTABLE:FILEPATH=${QT_QMAKE_EXECUTABLE})
-endif()
-
find_package(PkgConfig QUIET)
if(PKG_CONFIG_FOUND)
add_RunCMake_test(FindPkgConfig)
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -407,13 +407,6 @@ if(BUILD_TESTING)
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
- if(NOT DEFINED CMake_TEST_Qt4)
- set(CMake_TEST_Qt4 1)
- endif()
- if(CMake_TEST_Qt4 AND NOT QT4_FOUND)
- find_package(Qt4 QUIET)
- endif()
-
if(CMake_TEST_Qt4 AND QT4_FOUND)
# test whether the Qt4 which has been found works, on some machines
# which run nightly builds there were errors like "wrong file format"