tn3399_openwrt/target/linux/x86/patches-3.10/011-tune_lzma_options.patch
Gabor Juhos 11b1887c53 x86: add support for 3.10
Add kernel configuration and patches for Linux 3.10.

Taken from the 'alix2: update to LINUX_VERSION 3.10.9'
patch: http://patchwork.openwrt.org/patch/3971/.

Russell says in the original patch:

"Initial whack at updating alix2 to a current kernel. It builds
and runs without problems so far. I copied target/linux/config-3.8,
target/linux/x86/alix2/config-3.8, and target/linux/patches-3.8 to
their 3.10 equivalents and tweaked until it built.  The patches
required no changes."

The current patch contains additional configuration tweaks,
and the kernel patches were refreshed.

Signed-off-by: Russell Senior <russell@personaltelco.net>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

SVN-Revision: 37867
2013-09-02 07:36:40 +00:00

23 lines
745 B
Diff

--- a/scripts/Makefile.lib
+++ b/scripts/Makefile.lib
@@ -303,7 +303,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
quiet_cmd_lzma = LZMA $@
cmd_lzma = (cat $(filter-out FORCE,$^) | \
- lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
+ lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
(rm -f $@ ; false)
quiet_cmd_lzo = LZO $@
--- a/arch/x86/include/asm/boot.h
+++ b/arch/x86/include/asm/boot.h
@@ -23,7 +23,7 @@
#error "Invalid value for CONFIG_PHYSICAL_ALIGN"
#endif
-#ifdef CONFIG_KERNEL_BZIP2
+#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
#define BOOT_HEAP_SIZE 0x400000
#else /* !CONFIG_KERNEL_BZIP2 */