tn3399_openwrt/openwrt/package/nfs-server/patches/build-config.patch
Felix Fietkau fb153b0152 add libwrap, portmap, nfs-server
SVN-Revision: 450
2005-03-24 23:17:53 +00:00

68 lines
1.8 KiB
Diff

--- nfs-server-2.2beta47.old/site.mk 1970-01-01 01:00:00.000000000 +0100
+++ nfs-server-2.2beta47/site.mk 2005-03-24 22:42:20.000000000 +0100
@@ -0,0 +1,11 @@
+#
+# Site-specific make options generated by BUILD. Please do not edit.
+#
+
+# ugidd support
+UGIDD_PROG=
+UGIDD_MAN=
+# Location of tcp_wrapper library
+LIBWRAP_DIR=-L/usr/share/stuff/src/openwrt/experimental/buildroot/build_mipsel/staging_dir/lib
+LIBWRAP_LIB=-lwrap
+DEVTAB_FILE=
--- nfs-server-2.2beta47.old/site.h 1970-01-01 01:00:00.000000000 +0100
+++ nfs-server-2.2beta47/site.h 2005-03-24 22:44:19.000000000 +0100
@@ -0,0 +1,50 @@
+/*
+ * Site-specific configuration options generated by BUILD.
+ * Please do not edit.
+ */
+
+/*
+ * If ENABLE_DEVTAB is defined, nfsd will use the new inode
+ * number generation scheme for avoiding inode number clashes
+ * on big hard disks.
+ */
+/* #undef ENABLE_DEVTAB */
+
+/*
+ * If MULTIPLE_SERVER_READWRITE is defined, you will be able
+ * to run several nfsd process in parallel servicing all NFS
+ * requests.
+ */
+#define MULTIPLE_SERVERS_READWRITE
+
+/*
+ * If ENABLE_UGID_DAEMON is defined, the real rpc.ugidd is built,
+ * nfsd is built to support ugidd queries.
+ * Otherwise, a dummy program is created
+ */
+/* #undef ENABLE_UGID_DAEMON */
+
+/*
+ * If ENABLE_UGID_NIS is defined, nfsd will support user mapping
+ * vie the client's NIS server.
+ */
+/* #undef ENABLE_UGID_NIS */
+
+/*
+ * if HOSTS_ACCESS is defined, ugidd uses host access control
+ * provided by libwrap.a from tcp_wrappers
+ */
+#define HOSTS_ACCESS
+
+/*
+ * Define correct ownership of export control file
+ */
+#define EXPORTSOWNERUID ((uid_t) 0)
+#define EXPORTSOWNERGID ((gid_t) 0)
+
+/*
+ * If WANT_LOG_MOUNTS is defined, every mount request will be logged
+ * to syslogd with the name of source site and a path that was
+ * it requested
+ */
+#define WANT_LOG_MOUNTS