tn3399_openwrt/package/utils/busybox/patches/111-i386_no_arch_flags.patch
Matthias Schiffer b8d9a064f0
busybox: remove i386-specific build flags
busybox tries to be smart and passes a number of additional flags to the
compiler. Unfortunately, the i386-specific flags break ABI compatiblity
with libc.

Fixes busybox crashes observed on x86-generic with GCC 7.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
2018-03-12 12:49:03 +01:00

11 lines
445 B
Diff

--- a/arch/i386/Makefile
+++ /dev/null
@@ -1,7 +0,0 @@
-# ==========================================================================
-# Build system
-# ==========================================================================
-
-# -mpreferred-stack-boundary=2 is essential in preventing gcc 4.2.x
-# from aligning stack to 16 bytes. (Which is gcc's way of supporting SSE).
-CFLAGS += $(call cc-option,-march=i386 -mpreferred-stack-boundary=2,)