tn3399_openwrt/target/linux/brcm47xx/patches-2.6.23/110-flash_map.patch
Gabor Juhos 4da0e6f235 refresh kernel patches
SVN-Revision: 11200
2008-05-19 08:08:23 +00:00

30 lines
1.2 KiB
Diff

Index: linux-2.6.23.17/drivers/mtd/maps/Kconfig
===================================================================
--- linux-2.6.23.17.orig/drivers/mtd/maps/Kconfig
+++ linux-2.6.23.17/drivers/mtd/maps/Kconfig
@@ -352,6 +352,12 @@ config MTD_CFI_FLAGADM
Mapping for the Flaga digital module. If you don't have one, ignore
this setting.
+config MTD_BCM47XX
+ tristate "BCM47xx flash device"
+ depends on MIPS && MTD_CFI && BCM947XX
+ help
+ Support for the flash chips on the BCM947xx board.
+
config MTD_WALNUT
tristate "Flash device mapped on IBM 405GP Walnut"
depends on MTD_JEDECPROBE && WALNUT
Index: linux-2.6.23.17/drivers/mtd/maps/Makefile
===================================================================
--- linux-2.6.23.17.orig/drivers/mtd/maps/Makefile
+++ linux-2.6.23.17/drivers/mtd/maps/Makefile
@@ -33,6 +33,7 @@ obj-$(CONFIG_MTD_PNC2000) += pnc2000.o
obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o
obj-$(CONFIG_MTD_RPXLITE) += rpxlite.o
obj-$(CONFIG_MTD_TQM8XXL) += tqm8xxl.o
+obj-$(CONFIG_MTD_BCM47XX) += bcm47xx-flash.o
obj-$(CONFIG_MTD_SA1100) += sa1100-flash.o
obj-$(CONFIG_MTD_IPAQ) += ipaq-flash.o
obj-$(CONFIG_MTD_SBC_GXX) += sbc_gxx.o