tn3399_openwrt/target/linux/generic/patches-3.6/832-ledtrig_usbdev.patch
Florian Fainelli 7e856e5a97 make all 3.6 patches apply and build
SVN-Revision: 33911
2012-10-24 13:05:22 +00:00

32 lines
1.0 KiB
Diff

--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -548,4 +548,11 @@ config LEDS_TRIGGER_NETDEV
This allows LEDs to be controlled by network device activity.
If unsure, say Y.
+config LEDS_TRIGGER_USBDEV
+ tristate "LED USB device Trigger"
+ depends on USB && LEDS_TRIGGERS
+ help
+ This allows LEDs to be controlled by the presence/activity of
+ an USB device. If unsure, say N.
+
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -65,3 +65,4 @@ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) +=
obj-$(CONFIG_LEDS_TRIGGER_TRANSIENT) += ledtrig-transient.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
--- a/drivers/leds/ledtrig-usbdev.c
+++ b/drivers/leds/ledtrig-usbdev.c
@@ -24,7 +24,6 @@
#include <linux/list.h>
#include <linux/spinlock.h>
#include <linux/device.h>
-#include <linux/sysdev.h>
#include <linux/timer.h>
#include <linux/ctype.h>
#include <linux/slab.h>