tn3399_openwrt/target/linux/ipq806x/patches/0132-XXX-Add-boot-support-for-u-boot.ipq-image.patch
Luka Perkov 02629d8f87 kernel: update 3.14 to 3.14.18
Targets were build tested and patches are refreshed.

Signed-off-by: Luka Perkov <luka@openwrt.org>

SVN-Revision: 42463
2014-09-10 21:40:19 +00:00

49 lines
1.4 KiB
Diff

From 776fff11c1bf57e564a386521e56c277287a568c Mon Sep 17 00:00:00 2001
From: Kumar Gala <galak@codeaurora.org>
Date: Thu, 8 May 2014 13:40:16 -0500
Subject: [PATCH 132/182] XXX: Add boot support for u-boot.ipq image
---
arch/arm/Makefile | 2 +-
arch/arm/boot/Makefile | 11 ++++++++++-
2 files changed, 11 insertions(+), 2 deletions(-)
--- a/arch/arm/Makefile
+++ b/arch/arm/Makefile
@@ -302,7 +302,7 @@ archprepare:
# Convert bzImage to zImage
bzImage: zImage
-BOOT_TARGETS = zImage Image xipImage bootpImage uImage
+BOOT_TARGETS = zImage Image xipImage bootpImage uImage uImage.ipq Image.gz
INSTALL_TARGETS = zinstall uinstall install
PHONY += bzImage $(BOOT_TARGETS) $(INSTALL_TARGETS)
--- a/arch/arm/boot/Makefile
+++ b/arch/arm/boot/Makefile
@@ -25,7 +25,7 @@ INITRD_PHYS := $(initrd_phys-y)
export ZRELADDR INITRD_PHYS PARAMS_PHYS
-targets := Image zImage xipImage bootpImage uImage
+targets := Image zImage xipImage bootpImage uImage uImage.ipq Image.gz
ifeq ($(CONFIG_XIP_KERNEL),y)
@@ -80,6 +80,15 @@ $(obj)/uImage: $(obj)/zImage FORCE
$(call if_changed,uimage)
@$(kecho) ' Image $@ is ready'
+$(obj)/uImage.ipq: $(obj)/Image.gz FORCE
+ @$(check_for_multiple_loadaddr)
+ $(call if_changed,uimage,gzip)
+ @$(kecho) ' Image $@ is ready'
+
+$(obj)/Image.gz: $(obj)/Image FORCE
+ $(call if_changed,gzip)
+ @$(kecho) ' Image $@ is ready'
+
$(obj)/bootp/bootp: $(obj)/zImage initrd FORCE
$(Q)$(MAKE) $(build)=$(obj)/bootp $@
@: