tn3399_openwrt/package/ppp/patches/010-use_target_for_configure.patch
Hauke Mehrtens d21f38210a refresh patches
SVN-Revision: 15958
2009-05-21 10:49:21 +00:00

20 lines
426 B
Diff

Use values exported from $(TOPDIR)/rules.mk for determining
the target system instead of the host configuration
--- a/configure
+++ b/configure
@@ -8,9 +8,9 @@ SYSCONF=/etc
# if [ -d /NextApps ]; then
# system="NeXTStep"
# else
- system=`uname -s`
- release=`uname -r`
- arch=`uname -m`
+ system=${UNAME_S:-`uname -s`}
+ release=${UNAME_R:-`uname -r`}
+ arch=${UNAME_M:-`uname -m`}
# fi
state="unknown"